Out of Memory Error. What's the Fix?

Kindly help me urgently.
How can I fix the memory issue when its not letting me clear it. I tried to go to purge unused option, but it doesn’t function and says, out of memory.
Its not auto saving either. Can anyone help with it??

The first step is to shut down everything except SketchUp so that nothing is competing with it for memory.

There is nothing else to shut down. Only sketchup is running.
The file is 269 mb.

That is a very big file… I get some lag on a model of a fully framed house that is 1/10th the size of your model.

Not sure what shape your model is in, but turning off un-needed layers would help. If possible, breaking it into multiple, smaller models would probably be the best way to make is usable.

If most of the 269 MB is in unused components and materials, you could try selecting everything you want to keep and copying/pasting it into a new empty document, possibly in several stages as Aaron suggested.

Or, if you have a friend who can run the 64-bit version of SketchUp (has a 64-bit operating system) you could try to have him/her perform the purging for you

Anssi

You would be surprised what is really running. SU cannot run without a lots of support.
If you really only have a 32 bit system the max RAM you can use is 4GB but that is shared 1/2 SU and 1/2 with the operating system (video memory and a few other things are counted against the system allocation).
Can you run other SU models that are smaller?
Does windows ,w/o SU, run ok; can you log on to other web sites and use them ok.
I think the Su folks use a program called Priform Speccy you can run and it will aduit your system and give report to you on what you have installed etc. See if you can load that and run. Suggest you do that first so you / they know what you have.
You can allocate disk memory ( called paging file)which gets used buy windows as virtual RAM ( disk memory) but that is slow and probably not help much.


Above some partial audit for my system.
See if you can upload the file to Google drive or drop box maybe someone can open and help. If you can open post URL here so we can find/ try to open.
Max I have been able to open in past ~400MB

Most likely too you have more background processes running on your computer than needed. To check, at system startup, open Task Manager. The goal is to have less than 50 processes.

To help from inside SU, do you have a fast rendering style scene - no edges, no shadows, monochrome,no sketchy edges, minimal layers enabled, etc? Try selectively purging from such a scene.

Thankyou so much.
I am now trying to save it in smaller models.