Array copies: limit to 2 everytime, every

I’m got a head scratcher here. I cannot get arrays to make anything other than 2 copies in a single axis
Screenshots included as Screencast Links below
Macbook Pro 2018, Sketchup PRO 2018

I’ve got a simple tube component. In sequence:
(a) select the object/component
(b) activate the MoveTool
(c ) click the base point of displacement
(d) tap the (OPT) key for copy once (Mac)
(e) begin moving in red axis direction - it successfully copies as expected
(f) type the displacement (3/4") followed by
(g) the number of copies in array (10x) followed by
(h) ENTER
And the result is two copies. Every time.
It does not matter if I type 1 or 10 or 100. Its always 2 copies
Ive re-created the geometry in a fresh doc - same thing

Screenshot here: 2-Copy Array Screenshot
(The brown plane you see is a different, discreet group, simple planar surface)

Similar result when copying a simple cube in a fresh document, drag-copy using the rotate tool, only this time the only result I can get is 1 duplicate, no matter how many instances I type, 1x, 10x, 100x

Do I have some sort of corruption in the app?

Hit Enter between the distance and the number of copies.

Dave R - Yep, I’ve tried that. And virtually every combination I could find in the forums: (*) instead of (X), character before the integer instead of after, Displacement distance then (ENTER), then #copies, then (ENTER) or just displacement (space) # copies (ENTER) Always the same result: 2 copies.

Can you share the SKP file?

Here ya go DaveR
Array Copy Test.skp (40.5 KB)

This is what I get with your model. 3/4, Enter, x7, Enter. I tested it on my Mac and get the same results. I just don’t have a GIF capture tool on my Mac.

You aren’t clicking in the Measurements window, are you?

Make sure you don’t press the spacebar or anything else including mouse-clicks between:

How absolutely bizarre. In the sketchup tutorials, it clearly shows you can put the character X plus your integer in right after the displacement, e.g.: 3/4" x10.
But that might be windows. On mac I see from your animation capture that I have to delete/replace the displacement distance # with the copies #, and then POW - there they are as expected.

Thanks SO MUCH Dave R. Can I buy you a coffee? Seriously. If you use PayPal.me I’ll send you a fiver right now. You have saved my day.

What tutorial shows it that way? It’s never been the case that you could do that.

You don’t actually delete the move distance. After you type it in and hit Enter, you just start typing again. If you don’t enter * or x with the integer, the Move tool will regard that as a different distance. If you use * or x (or for that matter, /, it’ll regard it as the number of copies in addition to the original. It would be the same with radial arrays created with Rotate/Copy.

Happy I was able to help. No need for any payment… this time. :wink:

Have a great day.

Deep bow of gratitude, DaveR. I was expecting that maybe in a day or two someone might weigh in with a suggestion, but you answered my query in near real time. I’m pleasantly stunned. I’ll pay it forward, dear Sir. :grinning: Make a great day. (i’ll try to dig up the tutorial if Its still in my YT history)

2 Likes

I was actually wondering when you were going to get here and post your question. :smiley: :smiley:

Fortunately this one isn’t like help forums for a lot of other programs.

1 Like

Just wanted to follow up with an additional tip-o-the-hat to Dave R. Awesome assist. I’ve now been using the array feature with consistently expected results.