"Are you in the right place" error still there after the domain was whitelisted

After @CaseyG whitelisted the school domain (@4icudine.edu.it) a week ago we keep seeing the error “are you in the right place”.

I, as administrator, tried to:
_uninstall the app from the workspace
_eliminate the permission
_re-deploy the app
_re-garanted the permission

I did this a few times (cleaning from the browser the the cookies and the cache every time) and waited some days, but nothing changed.

Please help me to solve this issue.

Thank you.

Hi @aldox, I have verified that I added everything correctly on our end. Can you verify that the domain is correctly typed out in your post? I want to make sure I have everything in order before I go on to the next steps.

Additionally, can you post a screenshot of exactly what you are seeing? Please make sure to include the entire window so I can see all the information you are seeing. Sometimes I can glean some additional clues from the things like the URL or the bottom of the window.

@CaseyG Thank you. Here the screenshots

Same thing here. Looks like there is a whole thread of similar issues. Is the whitelisting of a domain a ‘real thing’ needed now? This has worked fine for us in the past. But for our staff at our root domain (wcpss.net) works fine on a Chromebook. Students, at @students.wcpss.net is doing this login loop.

We are experiencing the same issue with the “Are you in the right place” error.

Did you have a resolution?