Any tool to select circles of tube in one direction?

Is there tool to select circles like that?

E.g. to click on the tube, then use left drag to select the area and it would auto select the circles, except faces. It could be even useful on surfaces which are not exact tube.

Select View>Facestyle>Wireframe and select the lines only. You might have to toggle View>Hidden Geometry on as well , so you can see lines that are hidden. Best practice is to save these style settings as a new style (in the style window/tray) and save it , so you can use it in other models as well.

1 Like

Cool idea. But with that setting, I still need to struggle with the selecting vertical edges because there are horizontal edges too, which I do not want to include in my selection / view…

Thomthoms SelectionToys (and probably his QuadfaceTools) can do this…
(Edit: corrected plugin name)

I have this tool too, but I did not see that I can enable the toolbar :smiley: Thanx

It’s worth taking the time to learn about the extensions you install as you install them.


You mean Selection tools. Are you sure I can use it to select the vertical edges except the horizontal ones? Now trying the Edges icon and it selects edges, but all including vertical ones.

Yep, but it’s long time ago I used them or first time installed them.

He means Selection Toys.

You saw that it works in my GIF. Do you have Hidden Geometry turned on or did you have it turned off like I did?

Was turned on. Now I am trying to installed the new version of Selection toys. I downloaded the file tt_selection_toys-2.3.11.rbz and placed it to SU8 folder. Removed the old version, restarted but I do not see the ST menu item now. I cannot find minimal requirements info.

Note: your model contains normal edges, not hidden like the model of mine.

If you installed the latest version of Selection Toys, you also need to install the latest version of TT_Lib2.

So what? Unhide or unsoften those edges in your model.

You could also use Select Loop from ThomThom’s QuadFace Tools.

This isn’t the way plugins are installed. Do you have SU8 older than M2?

Good point Cotty.

Sorry, I placed the file and the library to Plugins folder under SU8. What is M2

i have 8.0.15158

Second Maintenance release of SU8.

What version of SU8 are you using?

I have v8.0.15158 and the built timestamp is 23.8.2012. That’s not that old I thing.

You can’t just download RBZ files and move them into the Plugins folder and expect them to work. The RBZ files are compressed and the contents need to be extracted. Starting with SU8M2 there is a built in utility to do that. Since you are using this ancient version, you’ll need to do some gymnastics. You’ll need to change RBZ to ZIP and then extract the contents of the ZIP file without destroying the file structure inside. That is, folders in the file need to be maintained. The extracted contents of the ZIP file all need to be placed in the Plugins folder and then SketchUp needs to be restarted to get it to load.

Much has changed since then.

OK, thanks so far. S.T. updated. Quad tools downloaded and extracted to plugins folder. But no Q.T. toolbar after restart.
I have the toolbar with 9 icons in S.T. The author, Thom has more icons on youtube video, did he install more plugins on the toolbar?

Is QuadFace Tools enabled in Preferences>Extensions?

Do you need those extra tools?

Look at Tools>Selection Toys>UI Settings. Enable all of the tools if you wish and save the settings. Do you really need a bigger toolbar?

You know, it’s time for you to think about upgrading your computer so you can use the current version of SketchUp.

1 Like