Using the select tool to select the outer surface of a cylinder


#1

I created a cable by first adding a circle to a flat bar. I then pushed the circle through the bar until it extended past the bar on the other side. I then selected the circle on the other side and by using the push/pull tool typed in 58’ and extended the cable. I then went to highlight the cable so that I could move the cable to a different layer. But, this is my problem, the inner portion of the cable highlighted and moved to my new layer, however, I am unable to select the 2 lines that form the outer surface of the cable so that I can move these lines to the new layer as well.

Help!


#2

Can you share your file or attach an image?

It seems like you could benefit by using groups or components.


#3

Seeing the model will be a big help but from your description, you are using layers incorrectly. All faces and edges should remain on Layer 0 which should always be the default. Only groups and components should get assigned to other layers.


#4

And SketchUp layers do not “own” geometry. Objects have a property that points at a layer, so it’s display behavior can be controlled by the layer’s settings.

Use groups and components to set geometry apart.


#5

I’ve seen what you describe and, as the others have suggested, it is due to incorrect use of layers. This is a good example of why we advise you to always leave ungrouped/non-component geometry associated with Layer0.

If you select a cylinder that is not a group or component and assign a new hidden layer to it, the softened/smoothed edges of the cylinder remain associated with the original layer and consequently SketchUp displays profiles for the (no longer visible) surface associated with those edges! Profiles are a sort of “virtual” edge that you can’t select or edit, so the situation is very confusing!

You can prove this to yourself in either of two ways: turn on view->hidden geometry and you will see the softened/smoothed edges as well as the profiles, or edit your style to turn off profiles and the mystery profile lines will disappear.

You can avoid this if you triple-click to select everything or if you turn on view->hidden geometry before you do the selection.

Some time ago I posted a discussion of this behavior, calling it an “inconsistency bug” because if you select the cylinder the same way and use the move tool on it, all of the edges and faces move together. So why don’t all of them also get associated with the new layer together? Trimble recognized the situation but hasn’t done anything about it, probably because they feel it is a user error rather than a bug.