Anti Aliasing after Geforce GTS 250 driver update from 2010 to 2014 drivers


#1

I’ve a little bit of a problem here with my sketchup 8.0.1.something.

My computer is about 5 years old and I hate updating stuffs. Because once I update some stuffs suddenly other stuffs stop working. My computer runs win vista home on 64 and my nvidia is a 250 geforce or whatever. Drivers from 2010. Works with sketchup like a charm, without me even touching anti-aliasing settings in either sketchup or the nvidia control panel.

Besides sketchuping I also play wow (feel free to laugh, if you must). Yesterday there was a wow patch that basically forced me to update the video drivers because I couldn’t see my characters in the game. Hooray, wow now works fine.

The problem is, my sketchup now looks like… well… you know. Every single line in sketchup is jagged, unless I stick to the preset left right front back top or iso points of view, which is pretty much a no go.

What puzzles me is the fact that with the same hardware but with newer drivers, sketchup looks a lot worse than it used to with my old drivers. I don’t get it in the least.

And before you ask, I’ve done the driver update a couple of months back and as soon as I saw the way sketchup looked I just rolled back to my 2010 drivers and everything went back to peachy. Unfortunately, I do play wow for about 30 mins every day, so it’s kinda annoying to keep rolling video drivers back and forth.

I have tried to play with the nvidia control panel anti aliasing settings - since the opengl settings in sketchup are kind of limited, but it didn’t solve the issue. It did help a little bit, but my lines still look painfully jagged whenever I pan and orbit, and I do that a lot.

Settings like application controlled or enhance application don’t make a difference. The same with 2x,4x,8x,16x anti aliasing. No matter what I pick, no matter whether I allow sketchup to control the process or I force nvidia to do it, the result is always the very same jagged lines. With hardware acceleration on.

At this point I don’t seem to find a reason to keep using sketchup because it’s gotten to the point where it’s painful to the eye.

Does anyone have any suggestions, other than merrily rolling back and forth vide drivers? Thank you.


#2

You should keep the Antialiasing setting in the Nvidia control panel at Application controlled.

Just one question: did you restart SketchUp after making changes to the Antialiasing settings in the Window menu>Preferences>OpenGL dialog? The settings should take into efect only after restarting.

It seems personal. I have never been disturbed by the jaggies and I keep AA at 0x. When I need nice output I export raster images at about 2x or more of the final size needed, and downsample them in Photoshop using Bicubic resampling.

Anssi


#3

Thank you for your reply Anssi :slight_smile:

Before upgrading the video driver, I have had no need to touch any anti aliasing settings, neither in nvidia nor in sketchup. It just worked and it looked good.

I have tried masses of anti aliasing combinations between sketchup and nvidia. The only combination that helped a very tiny bit was selecting enhance application from nvidia and setting the anti aliasing in sketchup at 4x.

And yes, I kept restarting sketchup after each and every change I have made.

I’m aware that some people might not be annoyed by jaggies. But I am. When I look at a jagged line, I cannot but see it as a line, it’s merely a collection of small lines that are skewed to one side and that leaves me under the impression that my structures are not sound.

Unfortunately the effect presists even if I choose to hide all edges and decide to use hidden geometry. And even with everything hidden, the jagged edges are still there, especially visible when paning and orbiting, because you keep seeing the jagged edges changing their angle and length of the individual; jagged lines. I find the effect very disturbing.

I don’t really care about how things might look if I exported them or rendered them and so on. I only design for my own pleasure and I don’t share or sell anything I make. I might decide to do that at some point further down the line but for now I’ve no interest in that. As such, the exports looking nice after being exported has absolutely no meaning for me.

I don’t mean to sound condescending or anything. It’s just that I really love what one can do with sketchup because I have a load of ideas. And having this issue has basically prevented me from working on anything since the change in drivers. So yeah, there it is.

The entire point of my post is to question why I cannot select higher antialiasing than 4x within sketchup while the settings in nvidia control panel go up all the way to 16x.

Thank you :slight_smile:


#4

Still one question:

Is your computer a laptop? Most laptops with Intel processors have an integrated Intel HD graphics chip even when equipped with a “real” graphics card, and to save power the OS is pushing applications to use the Intel chip to draw their screen even when inappropriate. If you are in this situation, you should check in the Nvidia 3D application settings that 3D applications in general and SketchUp in partgicular are set to use the Nvidia card for OpenGL. The default automatic selection does not seem to work well here, especially in Win 7. Screenshot from my Win 8.1 ultrabook below - it might look a little different in your driver version or OS.

Anssi