An error occurred while processing your request


#1

“An error occurred while processing your request. A network timeout occurred while uploading the file. Please try again.”

I have tried several times over the course of three days to upload my model to the 3D Warehouse. I can find no discussion on such an issue, or even anything similar.

I checked out this thread >> I can't upload my model to the 3D Warehouse, but I saw no solution - I think the OP never returned or something. And a link in that thread does not appear to address my issue. One person who replied in the above thread asked what version of IE the OP was using, but from reading other posts, I see nothing to indicate that IE must be used to upload or download directly from the warehouse (vs doing so from inside Sketchup). Despite not trusting IE, I signed in and attempted to upload my model in IE (11.0.9600.17959) - I got the same error message.

Windows 7 Home Premium SP1
Display and disk(s) set never to turn off when computer is plugged in; I do not use any sleep or hybernation settings; no “power saver” plan set

Firefox 41.0.2
Browser set to clear cache, browsing & download history, logins and form & search history upon closing the browser - so the cache is not the problem.

Google Sketchup 8.0.4811
I have never uploaded anything to the warehouse before.
I have downloaded from the warehouse on two or three occasions (last year- same computer, same environment) via my web browser
The .skp file is 47.4MB, and was stored on an external drive. I moved the file to the desktop to see if that would make a difference - it did not. I would think that if the file size were the issue, a message to that affect would be presented, so I’m thinking that is not the issue.

A November 2015 thread indicated the poster was having problems with uploading, but replies only asserted that uploading works - no questions, no requests for more info, no suggestions or solutions.

In googling this error message (since I can find nothing in this forum), I am wondering if the issue lies with cloud.materialise. com, and if that is the case, what then? Thanks in advance for help in why I get the above mentioned error - what I need to do (if there is a problem on my end) to upload my model to the warehouse.


#2

Hi @SketchrUppr,

Have you tried through the website itself using your prefered web browser?

https://3dwarehouse.sketchup.com/

This help article describe why you cannot access the 3d Warehouse from within Google SketchUp 8 anymore…

http://help.sketchup.com/en/article/3000177


#3

will try to connect to Google Warehouse, which no longer exists and stopped forwarding requests last year…

you need to search for the published ‘fix’ and see if it works for you, or upgrade to a much latter version of SU…

john


#4

Here’s the article for the fix I believe @john_drivenupthewall is referring to:

http://help.sketchup.com/en/article/3000180


#5

Ah, @SketchrUppr, you’ve jumped to a new thread from What makes a great 3D Warehouse product model?. In Google days, models were limited to 10 MB. We’ve upped it to 50 MB, so you’re close to the limit.

You should update your client SketchUp, or point your browser at https://3dwarehouse.sketchup.com/upload.html


#6

I have encountered the same issue … last month I tried to upload a 19.8MB model and I got an error in Chrome and IE from three different computers. Earlier this morning, I tried uploading a 38MB model and got the same error. The error message indicates that it is a network timeout issue, but none of my browsers are apparently able to keep the connection active long enough to finish the upload. I can still upload smaller models (I uploaded a 6.3MB model this morning).

Using Firefox Developer I just now tried to upload a 44.1MB file and got this after a couple of minutes:

Very annoying, to say the least ;(


#7

denisroy, john -
I have not tried to upload thru SU… all my attempts have been in Firefox (my preferred browser) and Internet Explorer at https://3dwarehouse.sketchup.com. I have never tried to access the warehouse from within SU. I have gotten many prompts in SU to share my work, but I have always closed them, and gone on about my business.

denisroy -
The link you provided indicates that the information contained therein is related to changes that affected SU Pro 2013 and SU Pro 8. I am not using a pro version of SU, and therefore do not know if the .dat file involved in the fix is compatible with SU 8, or any other non-pro version of SU.

Barry -
I came to this particular forum so that I could continue with trying to find out why I am unable to upload my model - the thread on which we “met” had nothing to do with this issue, so I did not want to further run it off topic.

That said, https://3dwarehouse.sketchup.com/upload.html?type=model << this is the page where I have attempted to upload my model. Is this not the same page for which you provided a link?

Thanks, guys… I appreciate your efforts.

@jimhami42 jimhami42 -
I notice you have listed three versions of SU in your profile. Which version of SU were you using when you got the error message? If it was anything newer than SU 8, I would think the issue has nothing to do with the version I am using (SU 8), as has been alluded to.


#8

@SketchrUppr, thanks for the clarifications. I suspect you get the error message because you cannot upload your file within the http connection timeout time.

Here’s something you could try: In your Firefox browser, type about:config in the adress bar and hit enter.

Then search for the value network.http.response.timeout and change it from 300 to 1200 and see if it helps. You might need to restart your browser before the change take effects.

@Barry: I don’t know if the 3DW server’s http timeout value could be checked/changed if it’s too low?


#9

@SketchrUppr, slightly OT…
if you add the @ symbol the @denisroy, @Barry, @jimhami42, and myself etc… we will all get notifications of you replies…

john


#10

Okay…thanks @john_drivenupthewall. I remember reading that, but forgot all about it. I guess it’s obvious I’m not into social media. That “@” is sorta like what they do in facebook or twitter or something.


#11

OK, well, that indicates a connection timeout. How long was your upload taking before you got that, and what’s your internet speed?


#12

@denisroy -
I went into about:config and changed the value as you suggested. I then tried again to upload my model - no luck. So I signed out of everything and closed Firefox in case a restart was required for the change to take affect. I even went so far as to reboot… just to clear out any junk that might be hanging around… LOL.

Relaunched Firefox, checked to make sure the changes I made in about:config were still there, and then attempted again to upload my model - I still got the error message.

@Barry -
“How long was your upload taking before you got [the error message]?”
-Approximately 2-1/2 minutes. Though I timed this after changing the value of the response timeout as suggested by @denisroy from 300 to 1200, I think I was getting the error in about the same amount of time before.

“What’s your internet speed?”
-10.48mbps d/l, 1.06mbps u/l (bandwidthplace.com)
-11.10mbps d/l, 1.18mbps u/l (speakeasy.net)
-11.20mbps d/l, 1.10mbps u/l (testmy.net)

Does the upload speed really mean anything? I mean, if an upload has begun, and continues uninterupted, it should continue until finished, shouldn’t it? Seems to me the timeout error has more to do with a lack of a response, or communication between two points before the upload has even begun.


#13

Is it possible that there is a server-side timeout of 150 seconds that wasn’t there a few months ago? I successfully uploaded a 44.1MB file from work (250Mbps nominal upload speed), but still can’t upload from home. Note that my home upload speed (at best) is 800Kbps. A 44.1MB file is 44.1 * 8 * 1024 * 1024 bits and would take about 460 seconds (at best) to upload which is what I’m used to in the past for large files (typically about 10 minutes for a file this size). This problem would not be noticeable to anyone uploading small files or with an upload rate of 2.7Mbps or better for 50MB files.


#14

@jimhami42 -
You may have something with this theory. I’ve given up on uploading the house I “built,” but today, I thought I’d try another model - this one, only 2.4MB. It uploaded >snap!< just like that.

So while the 3DWH indicates that models as large as 50MB can be uploaded, it appears that many models - at least the marjority of what I’ve seen while casually cruising around the warehouse - are well under 15MB, most times under 10MB. This could be why it seems that no one realizes what I’m talking about. I cannot thank you enough for your input into this issue as it validated my experience.

I do hope however, that it will eventually be discovered what the issue may be with uploading larger files, if indeed there is one - my experience in attempting to upload one, and your findings yesterday seem to point to the possibility.

Thanks to everyone who took the time to try to help.


#15

It doesn’t look like it is a large file issue.
I just uploaded a 48mb file without a problem.


#16

What speed ISP are you using, and how long did it take?


#17

At most, 5 minutes.There are only 13 minutes between posts and I had to read it then bumble about and find a suitably sized model, sign in, sign in again when I remembered my password and then upload. I posted another thread elsewhere while waiting then once it uploaded I checked it worked in the 3d viewer and then confirmed that it worked for me.
At this speed.


#18

So, a lot more time than the 150 sec timeout that @jimhami42 was speculating about…


#19

My uploads fail exactly 2-1/2 minutes after I click the upload button. I have repeated this half a dozen times. Always stops at 150 seconds. @Box … can you confirm that your upload lasted longer than 150 seconds?


#20

Yes, that’s our timeout. We’re lengthening it. Stay tuned.