AMD and Open GL / Graphics Card Recommendations?


#1

I’m using an AMD FirePro V3900 which I purchased because its description says “Full OpenCL™, OpenGL and DirectX® 11 support” … and yet I’m unable to run SU Pro 2015 without disabling hardware acceleration (ie SU does not use my graphics card).

I’m seeing lots of posts that AMD is known for not actually supporting OpenGL fully… but it says “FULL OPENGL” support… so I’m fairly confused about what I spent my money on and how to make this machine work for me. I use the software professionally and need it to work quickly and reliably, and yet am having all kinds of odd glitches.

Is there anyone who can help clarify or suggest steps to take? If there ARE no steps to take, suggest a good graphics card?


Graphic card recommendation
#2

I would never believe “FULL OPENGL” suppport. OpenGL 4.5?

Apple publishes https://developer.apple.com/opengl/capabilities/ . For goodness sakes, unless you’re buying these computers from the Salvation Army, call and complain about the graphics card they sold you. Macs are not void of OpenGL issues, but there’s sure a lot less headaches than PC’s.

-b


#3

It is a PC … It says open gl 4.0 on the graphics card info. I’ve
submitted to AMD forum as well but am I right in thinking open FL is the
issue?

emailing from my phone… apologies for brevity!


#4

It could be all sorts of issues that are not necessarily the video card’s fault.
Have you tried different configurations under preferences/graphics?
Reinstalling the card?
Disabling AMD drivers software?

I guess that card is specifically built for programs which use openCL but I would think that it should handle SketchUp alright.

Or I suppose it could be a bad card or who knows what.


#5

I did try changing preferences/graphics options. The program works, albeit
slowly and it seems from my research not using the GPU, if I turn off
hardware acceleration.

I did try reinstalling the card but I’ll give a whirl disabling driver
software (but that’s all set to “application default”. This is a new
machine with a clean install of windows and drivers…


#6

Did it come with the computer or did you install it? what CPU? Does it have Intel graphics built in? Could be a bios issue.
I guess the only way to eliminate all other issues is to try a different card.

I do not know how well that card would perform even with hardware acceleration most people use desktop gaming cards in the $250+ range. That card is really only for people who specifically need openCL -I would have to guess you could replace it with a $50 regular desktop card and get similar performance.


#7

quite the converse, Apple is well known for slow and reluctant development of the OpenGL stack:



http://lists.blender.org/pipermail/bf-committers/2015-May/045367.html

Our very active OS X platform maintainer for many years, Jens Verwiebe - had a
suprising statement. He’s going to abandon OS X as a serious 3D/graphics development
platform. This, he said, because of lack of quality GPU support (OpenGL, OpenCL)
and annoying Yosemite glitches. It makes this platform too painful to keep using seriously.

The OGL support of the video drivers on the Windows platform are more mature and performant simply because the makers of video cards do have a much longer experience and are more interested in developing their product further than the maker of the operating system.


#8

besides installing/using the latest driver version you may want check, that - in connection with an integrated video system (e.g. intel HD) - the “High-performance GPU” is running especially if on battery:

http://h10025.www1.hp.com/ewfrf-JAVA/Doc/images/639/c03750725.jpg

if nothing helps drop the FirePro and go for a nVidia GeForce GTX 750Ti/960/970/980 (slower <-> faster) preferrably as a 2-fan version from Asus or MSI.


#9

History, man, history https://www.youtube.com/watch?v=Qj3dPyk7hPI&feature=youtu.be

Read the complaint: it’s a about OpenCL with OpenGL, right? You probably know more about it than I, but Apple gave up the graphics fight of their own stuff with Mac OS X, while Microsoft continues on with Direct X, right?

Your last statement is correct - it’s the makers of the video cards. They’re making the drivers for both.

Let’s put it this way: if OpenGL went away, who would be screwed? Apple, Microsoft, or Graphics Cards companies? Only Apple… would they resurrect QuickDraw 3D?

OK, now back to the topic at hand…


#10

Thanks I’ll try that! And also for the card recommendation. I just want to
happily model so all the hardware research gives me a headache :wink:


#11

So, it looks to me like SketchUp is not using my graphics card- in OpenGL
Details I see renderer as GDI Generic- shouldn’t that show my GPU?

[image: Inline image 1]

On Thu, May 21, 2015 at 10:25 AM, Sarah Steinberg <sarah.steinberg@gmail.com


#12

Yes -mine shows my graphics card regardless of whether hardware acceleration is checked or not

Based on that I would say your card is either not installed correctly or malfunctioning.


#13

so, other than updating drivers, which I’ve tried repeatedly, what can I do
to resolve that? any thoughts?


#14

Go to your Catalyst Control Center. Look for something like Norbert shows above about choosing your GPU, except look for an option to specifically choose the GPU used for individual programs. Check if SketchUp is set to use the high-performance GPU.


#15

Take it to a technician who can fix it.


#16

Sometimes older drivers may work better. The OpenGL content in the driver is a bunch of function calls, around 300. Quite a few apps that use OpenGL don’t need all of them so driver developers may leave out the less popular function calls. AMD card development tends to be biased toward gamers and their needs.

SU relies on more OpenGL functionality than many other programs. And some of the less popular function calls are required. If things are missing from the driver, SU can’t use your GPU.

In Catalyst, is your anti-aliasing and anisotropic filtering set to application controlled?

In SU, try disabling fast feedback in Window > Preferences > OpenGL.


#17

surely true for the Radeon consumer series but doubt this for the FirePro (formerly FireGL) professional series.

SU currently requires OGL v2.0 which shouldn’t be to demanding and is typically fulfilled by the drivers of most consumer cards targeted to the 3D gaming market… better or worse :wink:


#18

Well according to him SketchUp is not even recognizing the card so most likely it is a driver or system Bios issue -(or defective card I suppose).

We never heard back about the integrated graphics question.

He does not actually even need Catalyst to use the card and it could be disabled to check if it is causing problems. Sometimes it is necessary to fix a device issue manually through device manager.


#19

I got the info from one of the QA folks that some of the function calls SU uses are some the lesser used OpenGL function calls industry wide. Now even saving files uses OpenGL. AMD has a very spotty record - SU-wise. Though my first two cards were Radeons and they worked fine with SU with hardware acceleration, although I needed to disable fast feedback. With one of those card, SU would not open if fast feedback was enabled.

The SUpper who could not save a file if hardware acceleration was enabled had an AMD card. But he was otherwise able to model with hardware acceleration enabled.


#20

It recognizes the card if hardware acceleration is checked (but crashes);
it does not if unchecked.

I have tried the settings in the firepro control center 3d Application
Settings- both set to “use application settings” and not, and with a
special profile for SketchUp, both “use application settings” and not.
[image: Inline image 1]

Tried reinstalling SU, installing 32 bit SU, installing SUPro2014.
Reinstalled drivers for GPU.

Good to know that even saving is an OpenGL call!

So looks like my last effort is to try uninstalling and reinstalling GPU
(or waiting for AMD to get back to me on my service request)… It is
frustrating because as one commenter noted, this is supposed to be a
workstation graphics card for CAD and 3D modeling workers, which is why I
bought it- I’m not a hardware genius or anything but I did do some research
beforehand- Well, I’ll try reinstalling GPU when I have a minute between
projects and update you all if that works, and otherwise I guess decide
between service and a NVIDIA card. I bet the card would be cheaper.

Thanks for your suggestions, all.