Admin approval - Sketchup for education

Hi I’ve just deployed sketchup to all machines via sccm from the windows store.
No issues except when opened and you sign in users get the message saying they need approval. Except for my account that is.
I’ve been into azure and the enterprise applications sections. Found sketchup for education and added the student and staff groups to the app and clicked grant access in the permission section.

Still we get the same message. What am i missing?

I asume you are talking about SketchUp for Schools, so I changed the category to alert the right people @SketchUp_Moderator

Hi Jason, could you please provide me with your school’s domain address? In some cases a school domain will be mistakenly identified as not being educational. I can add your domain to our whitelist to see if this helps solve your issue.



Hi Tori

Can you let me know when its added please and i’ll give it a test

Hi Jason.

You’ve been added to our whitelist. Please let us know if you have any other issues.

Hello, could you add my shool domain to whitelist - Thank you.

Hi Jolita,

You’ve been added to our whitelist. Please also make sure that the app has been allowed by your administrator, as whitelisting does not remove this requirement.

Hi Tori
I’ve tried the login today but i get the same message telling the user to get permission from the administrator.
If i log in as me into Sketchup it works

Maybe i’ve done Azure settings incorrectly? Is there some guidance?

Can you please also add the following domain to your whitelist
Some of our accounts are defaulting to this rather than our domain name


@Jason2234uk Just to confirm, one of those domains includes the spelling “hwga” vs the other being “hwgs”. Are they intended to be different?

Sorry yes its a typo
our domains are and

Both of your domains have been manually registered. Please let us know if that helps!

Hi Tori

It still hasn’t changed the issue. As soon as we try to log in with an Office 365 account and it says it need admin approval. It only works for my account which i’m guessing is because i’m the global admin
I’ve added in permissions for users, set user assignment required to no in Azure. Still the same result