Added layer not showing up in entity info

bug

#1

Not sure if it’s the massive file size of the model but lately I have had a lot of "SketchUp make 2017 (Not responding) and black screens every five to ten minutes. Just now I created a layer and when I tried to add a group to it the layer did not show up in the Entity info box for layer. The POOLPUMPRAFTERS was existing and the new layer POOLPUMPRAFTERFEET maybe the problem. The syntax is very similar and I seem to recall in 2015, 2016 having the same problem. The layer added shows up in the Layers list but not in the Entity info Layer drop down. I will have to change the name to see if it works to POOLPUMPFEET and get back. In any case I’d like to submit the following .jpg files and ask for comments and advice from those that know more about SketchUp. Thanks in advance.
I do have the new SketchUp Checkup 2017 and it has passed without errors when it runs. I also stream movies while drawing on my HDMI screen extender to Panasonic Flat screen smart TV. Checkup passed all while doing so even if it took a long time to do so.

I was right, the name change worked but it makes me wonder if the memory is getting overloaded with multiple layers of similar syntax ending up with dramatic slow down even at 7% of CPU usage and 51% of memory usage. Any advice greatly appreciated. Funny enough, SketchUp Make 2017 only crashed once while I was running the model, a movie and Checkup at the same time. Not sure if I should run Checkup with the model closed as it might only read the system itself as appropriate rather than operation processes?


#2

Do you have autosave eneabled in the preferences? For a big model, this saving every … minutes can take some time…


#3

Sorry about the delay in responding. I had the auto save set to 25 minutes and changed it to 90. Strangely enough I believe the PC needs to be Re-booted before the change takes effect. Dew to UPS usb -cable and other problems I haven’t taken the time to re-boot so if any one knows I’d be greatful to know if the preference/auto save takes affect without re-booting? I guess I’ll find out today. I’m actually using 3d cinder blocks to build walls and mesh and rebar etc. Something that really put the hurt on AutoCAD way back circa 486 systems. Too bad I won’t be able to run AutoCAD to compare the two systems memory usage for real 3d. So far Ruby seems to be kicking Auto-lisp’s butt. Black screens every auto save or array sure beets the complete crashing.