Add location cannot parse location info when input format is sexagesimal: Recent bug!

geolocation

#1

Continuing the discussion from Can I enter coordinates (2d) into Sketch Up (Could be UTM or Lat/Long)?:
The link shows the geolocation near LA Joya Texas. When the OP inputs location as degrees, minutes and seconds SU returns the error shown " Sorry: Your noted address was not found." . However, when the location is converted to degrees the location is found consistently: 26.249325 -98.480978
Problem input 26°14’57.57"N 98°28’51.52"W and some times the program will find this location. This on line file converted found location with no problem http://www.sunearthtools.com/dp/tools/conversion.php.
The problem persists if GE cache is cleared both memory and disk, GE and IE text fonts set to type so the degree symbol is same( ie. alt+248) GE search history cleared. A number of input combination was tried.
Please post if you confirm issue


#2

I went ahead and submitted a bug report on this.


#3

Thank you. Does that imply you see the same problem??


#4

I tried your test location in Photo Texture. When I search for 26°14’57.57"N 98°28’51.52"W (using copy/paste), I get an error message: This location does not appear to have Street View coverage, or your internet connection may be down. But when I tried 26.249325 -98.480978, Street View worked.

When I tried Add Location, 26°14’57.57"N 98°28’51.52"W returned: Sorry, your address was not found. Inputting 26.249325 -98.480978 worked.


#5

I posted in the original thread, but just try typing or copy/pasting

in ‘Ruby Console’, do you see an issue with encoding?

I do on my mac…

john


#6

Yup


Error: #<SyntaxError: : syntax error, unexpected tIDENTIFIER, expecting end-of-input>
SketchUp:1:in `eval’


#7

maybe not the best test, as SU dosen’t recognise any degree symbol, [dooh]

I didn’t even input it, as it looks like this when I type it…

although it won’t work as an input, it at least stays the same when pasted into ‘Measurements’…

to get the wrong one to show here it needs to be escaped with a code block…

I think it’s a UTF-8 v UTF16 issue…

john


#8

Have not but will double check to make sure I did not miss


#9

Thanks the deg degrees seem to work well, the lat long input is a valid
one and even worked for me some times but not always. It would work
several times then stop for same input. That’s the reason i spent so
much time looking at ch ache etc. Su has a very interesting / strange
file tree on how they get the data. There are a number of execl files
they use and has the dimensional conversion, defines the above input
formats in them plus they establish a link to the international
association of oil and gas producers . You can register for free on
their site and they supply much of the data su uses for state plane, utm
other countries etc. etc.
IMHO SUhas made a recent change that broke what was usable for some time
even though Barry bitches other wise. I have personal opinion they do
poor job of regression test. I think they made recent change in that area.
Any way think beating dead horse:-D


#10

The dgree symbol is not usually mapped to many of the fonts used. I am not even sure Ruby is used for the location data, see my post above. For Times New Roman and Courrier New just input alt+248 and that is added. You can go to the control panel and check fonts and it has a link to key borad you can see where it is located=> different input for different fonts some time. I chaged the IE and windows fonts used on my machine to make sure that was not a problem.
If you inut the dgrees, seconds, minutes in the ruby input bar I get the same result, try the decimal degree and see what you get??