Unrecognized absolute Add Location coordinates

Hi Everyone!, im having this issue, Sketchup is not recognicing absolute view location coordenates when i try to search from the add location tool

I can’t find a reference for you, but I recall reading somewhere that the Pro version has an option to enter Latitude and Longitude. I have Make and have the same problem you have with specifying a location.

this works, but takes me to another place… whats the name of this type of location and where the “#39” comes from?


i ask because i saw one guy at the Sketchup official youtube account, doing it that way.

[totally changed for clarity] Okay, I was able to enter “36.055,-112.14” and get the correct location.

not since the js parsing was changed by Google and now both Make/Pro on PC or mac have trouble…

there is a least one other topic on this recently…


I have found typing absolute coordinates to be erratic recently (maybe, as John says, due to a change in Google’s API). It works sometimes once, but then gives the error. It also seems to remember the last value and refuses to change it. If you type the name of a place it seems to work more consistently.

On my mac it depends on the Font used for the degree symbol, some that I cut and paste work, but typing it fails…


Have you tried using decimal notation? + for North and East and - for South and West?

36 deg 17 min 16.21 sec N and 115 deg 10 min 43.14 sec W == 36.287836,-115.17865

1 Like

decimals are fine, but both used to work, I rarely use anything more than a post code and was only investigating a reported issue…


I tried a number of different approaches and finally found this to work:

36°17'16.21"N 115°10'43.14"W

Note that there must be a space at the beginning of the coordinates … delete the space and it doesn’t work. I added the degree symbol using the Windows “Character Map” but any way you can insert an ASCII 176 (decimal) character should work.

if I paste yours from here with a leading space it works in SU, if I try to type it, I can’t get past the 36 in…

##36 °
from the keyboard both there and here, it doesn’t generate the symbol…

it will also wipes out any trailing text if I attempt to type a replacement symbol onto an existing one…


How are you inserting the degree symbol? Have you tried “Option-K” or “Shift-Option-8”?

on a mac it’s normally ⌥k, but ⇧⌥8 does work here at least i.e. °

however, not in Add Location…


wao, so that was the issue…, Thank you very much Jim!

Thank you every one!

Your comment got me to thinking that, logically speaking, if a co-ordinate format can be digested by Google Earth, then it should be digestible by Google Earth from within SketchUp. If you browse to a location in Google Earth and add a placemark, you can cut-and-paste its latitude and longitude into SketchUp. I noticed that when I did this, that it added the space in front of the latitude (but not in front of the longitude). So, as a workaround:

For SU if you input boulder co. you will get a slightly different location vs the truth which is the USGS. Some locales have more than one USGS monument and only one is considered the truth. The link below may be interesting read for some

1 Like

Hi Everyone, about the Add Location tool, it’s seems cannot locate to an accurate geolocation.
When I add 24.992161,121.295051 into it. It gives me a center as result:

The locations are different (it changes to 24.992069,121.294934), so my model cannot locate to the correct location on Google Earth.

Is there any way to accurate locate the model in Sketchup? Thank you!

I would NOT call that inaccurate location. I would call it inaccurate centerpoint location - the centerpoint probably had a rounding error.

Move it to exactly where you want it. I tried it, and moved it to exactly where you wanted it from your pin location will give you that location.

1 Like