Move to absolute coordinate using European keyboard

Hi guys.

So I just started using SketchUp, however I can’t seem to get the move tool to work as expected. When moving any 3D object I am not able to get SketchUp to accept the 3D coordinate. Google yields arguments for using [x; y; z] for European keyboards, however when I do this it clears the cell before hitting the last “]” on the keyboard.

Is this a bug or am I missing something?

Thanks.

Are you putting spaces in when you type the coordinates?

I’ve tried with or without to no avail.

Hmm. See if it’s possible to change only one coordinate, still using the semicolon delimiter.

In other words, let’s say you have an object sitting on the ground plane and want to raise it to 10 meters above ground. With the Move tool, click the point on the object that will be at z=10m, start moving the mouse, and then type [;;10m]Enter, which says, same x; same y; z=10m.

That way, you can at least confirm that the general form of notation you’re using for absolute coordinates on a European keyboard works.

-Gully

You have to end the movement with the mouse before (release the object) and enter the absoulte coordinates after this. While the object is attached to the mouse cursor, it won’t work.

@anon92451023, are you certain you didn’t move the mouse / touched the touchpad just before keying in that last ] and hitting [Enter]? For then all input is lost and you’ll have to type the whole sequence [x;y;z] plus [Enter] again.

@DaveR, I’ve noticed that spaces do not matter when I input these coördinates except for at the end.
i.e,. one 0r more spaces between the z value and the last ] results in “Invalid length entered.”.

@Cotty, on my laptop it doesn’t matter whether I end the ‘Move’ operation with a second click or not. The input is accepted with preferences set to Click-move-click" or "Auto detect"
And “Click-drag-release” works after releasing the mouse button.

I’ve tried again and if I click the alt-key to enter the closing ], the vcb changes to the distance again…

Germany I guess. It seems to be the combination with [Alt] that make the difference for you.
I can just key in ].

I assume your PC is set to use a comma (,) as a decimal-point, rather than a full-stop (.)
so you type [1,2;3,4;5.0]
I have it set to a full-stop (.)
So I can type [1.2,3.4,5.0]
At what point do you get the failure ?
What keyboard are you using? on a UK / USA layout the [ and ] keys are to the right of the top row of letters.
Do you need to shift/alt+ to get a ] ?

With European keyboards (mine is Finnish), you have to use the AltGR modifier to enter square brackets, and this has always canceled the input, just as Cotty says.

Anssi

This is as I suspected…
:cold_sweat:
Download this ZIP and take the exe file out of it and put it into Windows StartUp folder so that it always loads as Windows [re]starts…
Double-click its icon now to see what it does without needing to restart Windows…

It sets up the following alternative key-strokes, invoked only when typing inside a window with SketchUp in its titlebar…

#IfWinActive SketchUp
  :*?:,,,::;
  :*?:///::]
  :*>:0/0/0::[0;0;0]
#IfWinActive

So to type a ; you can now type three , - thus ,,,
To type the impossible closing ] - you can now type three / - thus ///
To type [0;0;0] - aka the ORIGIN - you can now type 0/0/0
TypeTIG.zip (371.3 KB)
It is actually a simple compiled exe made from an AutoHotKeys ahk script…

This should be fixed in the SketchUp interface BUT it isn’t [yet]

1 Like

I had the same problem, driving me crazy. But a very easy fix. just hit the “enter” key after the laster number input. Just forget the closing square bracket. in my case [0;0;0 ‘enter’ . That works in my case.

1 Like