Having trouble typing in absolute coordinates due to danish key board lay out


#1

Hi all
I’m trying to type in absolute cordinates in the VCB (eksampel “[23,25,21]”). but dut to my Danish keyboard lay out i need to press alt gr+8 to get a [ and alt gr+9 to get a ].
I have no problen starting the input in the VCB. but when i try to finish it with a ] the alt gr keystrok wipes the VCB. Anybody got a work around for this ???
Tried copy/past from at text sheet to no avail.


#2

Do you use a comma as the decimal point? If so, you must type “[23;25;21]”.


#3

It’s the [ that is the problem.


#4

Have you tried with the on-screen keyboard? If it’s Windows, just search for it in the start menu.
(Alternativly, you can set up multiple keyboard layouts/languages that can be changed with a click - I normally spend some time trying to get rid of the english(US) layout.)


#5

This has been known for ages, it also occurs in say a FR-Canadian keyboard.
Until someone at Trimble bothers to fix it, then here’s a PC exe that let’s you do it.
It’s a compiled AutoHotKeys script - extract it from the ZIP [that’s because exe files cannot be attached directly].

You type /// instead of the closing ] and it replaces those with the ] for you…

You put the exe in the:
C:\Users\YourUserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
folder so it’s always loaded as the PC starts.

You can of course double-click it’s icon to run it to see if/how it works…

TypeTIG.zip (362.5 KB)


#6

Hi folks.

I have submitted this bugs for ages and still no solution. I am using a french canadian keyboard on my Mac.

I have exactly the same problem that when I type the closing bracket ], it wipes the Measurement window.

On my keyboard it is alt-9 and alt-0 for the [ and ] respectively.

Best regards.

Jean


#7

Same here. Finnish keyboard, the square brackets are AltGr-8 and AltGr-9. It has been the same since version 3.

Anssi


#8

does clicking into the ‘VCB’ avoid the issue?

I can’t remember…

john


#9

Clicking cancels the operation.

Anssi


#10

Currently the only workaround is to use something like my AutoHotKeys cludge…


#11

Have you tried to finish the desired action before entering the absolute coordinates? This is working for me (one of the AltGr-8 -9 guys)…

First part of animation: box floating at mouse, second with finished move action before coordinate entering…


#12

The closing ] is not strictly required.


#13

That is true, didn’t know that.
[0,0,0 enter works.