Coordinates brackets

Hey
I’m trying to enter coordinates with [3000,3000,3000].
First of all, the brackets wont stay if i dont hold down the ALT key. If i do and type the values “invalid lenght”

What am i doing wrong?

Sounds like a keyboard localization issue. You shouldn’t need to hold Alt to type the square brackets. At least on the standard US arrangement both opening and square brackets are accessed directly. Curly brackets would be accessed with Shift and the same keys as the square brackets without Shift.

BTW, are you still using SketchUp 2021 as your profile shows?

I’m using swedish keyboar. Square brackets ALT + 8/9
I have upgraded to sketchup 2022, i have also testet this on 2023, problem remains

I wonder if @colin has anything to add on this.

Please update your forum profile.

Have you tested it with SketchUp 2024? Since it is the current version, if there’s a fix required in SketchUp, it would be the version to get updated, not SketchUP 2022 or 2023.

I just testet 2024. Problem remains

I found a work around for this.

I changed my keyboard layout to US. When doing so the brackets don’t disapper.
The lenght i enter [500,500,500], is still not a valid length.
If i change the prompt to [500;500;500] it works.

Where can i repport this problem?

that’s because you live in the free world.

in the UN and a few other places, they use a decimal dot.
therefore, the comma is free to separate numbers.

In the rest of the world, we use a decimal comma. therefore we use a semicolon to separate numbers.

on a computer set to use a decimal dot, [500,500,500] should work. yours is set to use a decimal comma I guess so [500;500;500] it is.
the layout of the keyboard itself won’t influence this, as you’ve seen.
And yeah, in many keyboards I’ve seen, [ ] requires either alt (PC) or alt+shift (mac)

I get the saparation part.

If i use the SWE keyboard layout brackets is prompted by pressing ALT and 8 or 9 as mentioned before.

Problem here is that i have to hold down alt when typing my mesurements. When holding ALT key i cannot prompt semicolon

In the Finnish keyboard square brackets work with AltGr+8 and 9 so I don’t have to remember the alt+xxxx sequence.

I’m unfamiliar with Foreign versions of the program but could you resolve the issue by switching the keyboard to US?

it’s not a long term solution

if you switch to an US layout, then you still have no idea where to press to have the brackets, because your keyboard is printed in your own layout. plus, you loose all the fun local bits. I’m french, my keyboard is an AZERTY not QWERTY. Petter would loose the å and ö. and €

Do you have to hold ALT the entire time while you’re typing the text string? It seems to me you should be able to type the open square brackets with ALT+8 and then let go of the ALT key and type in the coordinates.

yep, just tried here, pressed alt + 5 (yes, it’s on 5 and ° here) then all I had to add was 0;0;0

Now I think about it, it was kinda broken in older versions, maybe 21 ? when the ctrl and alt keys had to be pressed for them to work.

unless your swede keyboard works differently ?

Using SWE layout i have to hold down alt. This means i cannot press semicolon
Using US layout it works as intended (exept for semicolon as separation, and not comma)

So when using this function I have to switch to US and then switch back

OK. I don’t have a Sedish keyboard but from what you say, if you wanted to type coordinates in square brackets in a text editor like Word you would also have to hold Alt the entire time so that the brackets will be printed?

I have to admit I am confused and curious about this. Are you saying that if you type the alt-key chord to create a square bracket you can’t release the alt key afterward because the square bracket will then vanish? That’s as if the system is waiting for some further character to complete a magic sequence for the bracket…

When you press Alt Gr + any key ( required for [ <) then release Alt Gr your input field is cleared (updating to current length from start to cursor). This is the situation currently on SU2024 if you are using Line tool on Windows. (Regional setting and keyboard: HU)
With ENG/UK keyboard you can do it without issues.


BTW:
Entering this “special” characters (. , ; [ ] <> ’ ") in SketchUp has never worked properly if you are using a non-English keyboard and/or region. One issue resolved by new releases of SU, the other issues are come back. This is happening periodically in a last 20 years.

In the past, when I worked a lot more in Sketchup, I had to attach a secondary English keyboard. (Using RightKeyboard program to automatically switch between keyboard layout depends on which kb I’m typing)

You native English speakers are lucky, because most of the programmers (99.99%) only think about the “English alphabet”, or they think wrong if the region is not English :wink:

1 Like

And 99% of them are American English :rofl:

1 Like

Huh, what a tricky little problem. Could you type a beginning square bracket somewhere else, like in screen note or a word file, then copy/paste it into the SketchUp Input field when you need it? You only need the first one, this would mean clicking into the VCB which is not normally done but it does work.