About time to fix the "Radius is too small or number of segments is too large for given angle."?

bugs

#1

I get this all the time. “Radius is too small or number of segments is too large for given angle.”

Then I have to create a bigger circle with the desired number of lines, then scale it down. Why this limit? Woud guess some 20-70% of all Sketchup users also gets annoyed by this. Please fix it.


#2

Until such time as the whole structure of the software is rebuilt to address the issue that also affects other software, try using the Dave method.


#3

That limit was imposed a couple of versions back when SketchUp got to be popular for 3D printing and users were trying to make small circles with hundreds of edges that when made 3D, resulted in non-watertight and thus non-printable groups. If the limit weren’t in place you’d be complaining because you can’t make 3D printable parts for your drones.

As Box said, for now, anyway, you can use the Dave Method to get around that limitation.


#4

Thanks for the fast answers. I am aware of the scaling method as I mentioned in the original post. I have to say this is a very impractical workaround that many people are forced to do. High number of polys in small objects might be impractical in 3d-printing, but that´s their responsibility when designing (most people print their own designs so they will quickly find out if they cant be printed properly). Also, the limitation doesn´t stop anyone from doing the high poly, just takes more time because you have to scale up and down all the time, also re-enter the circle setting that gets resetted. In the end, you end up spending 10-20% more time on the design… I have been using a 3d-printer for a year and never had any problems with my designs, even with the upscale/downscale method.

Button line is I think this limit is just doing a lot more harm than it benefits the 3d prints. It should be user selectable, also there could be warnings. Think you should make a poll, at least.


#5

You do know that you can model in meters and export as millimeters.
No scaling, no dave method needed.


#6

Considering the primary design brief for SketchUp is a tool for architects, I think it does a pretty good job of handling the tiny stuff.

Apparently you aren’t aware of the Dave Method.


#7

I see that the Dave method is a bit more complex workaround than just scaling… The fact that people are making videos and developing methods to avoid this just empasizes the problem. I am using Skechup Make. When I start a new project, all I see is a Maker Bot replicator working box. With other words, I am in a version / template for 3d printing and the default millimeter accuracy is some 0.000001 mm. For me, the solution is either do go back to an earlier version before this limit was added, or work in meters and export in mm.


#8

Skethup is not just for architects, and probably most users are not… I would have been using fusion for my bits and parts, but i find that program heavy and a bit complex. I like the simplicity Sketchup offers. Have tried a few others but they can´t compare.


#9

No. But it started out that way. It’s original market and still the largest professional market for it is for architectural use.


#10

One thing to consider, too, is that the resolution of 3D printers, especially the ones normal mortals can afford, is not something to write home about. So using a zillion segments for small circles is in most cases just a waste of computing resources as the printed result will be rough anyway.
Do I remember right that @jimhami42 was the person who posted a nifty way to calculate the optimum number of circle and arc segments for a given radius and printer resolution?


#11

Seems like Sketchup is based/encouraging low poly, because it constantly tries to stay in low poly mode (24 lines in a circle)
Maybe it´s time to move ahead a bit and allow a few bit more polys into the system. After all, computers are evolving, so should the Software…


#12

What if Sketchup would limit the polys according to that measure, would be perfect. Wish I could help writing that code.


#13

The problem isn’t low poly, it is very tiny poly. SketchUp (by original design) doesn’t like edges that are less than about 0.001 inch. Driving the number of sides of a polygon to a very high number tends to create such small edges, leading to lost faces and other glitches. Hence the warning.

There have been a lot of requests over the years for some way that users could set a smaller tolerance when working with small models. But (probably because there are workarounds such as the “Dave method”, the developers haven’t changed anything.


#14

The calculator is here: https://sites.google.com/site/spirixcode/code/jrh_n_calc.rbz

There’s also these threads with more:


#15

I just changed my settings from mm to cm, pretending to be working in mm. Pretty happy with the outcome so far. Creating components and scaling is unnecessary complex. Are the developers active on this forum?


#16

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.