A fix for Layout in High Sierra


#1

I try Layout every now and then, on the off chance Apple had done something that fixed the issue. They haven’t, but while I was checking I thought of a way to fix the problem.

If you have a hex editor you can find a line in the Layout executable, at around 3750, that reads:

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/libruby.2.0.0.dylib

Changing two of the zeros to threes fixes the problem, and Layout opens and runs just fine:

/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/libruby.2.3.0.dylib


Layout crashing on macOS 10.13 High Sierra Beta
#2

I think it’s odd that LayOut doesn’t use the SU ruby for more control…

john


#3

Indeed, since SketchUp embeds the Ruby framework into its app bundle and ignores the system’s installed version. Perhaps this was a result of a bit of carelessness while starting to develop the Ruby API for Layout?

Edit: install_name_tool is the official command-line tool to change the names of dynamic library references in an executable. Possibly safer than a hex edit.


#4

I could excute LayOut2017MR2 on my MacBookPro2017 (macOS HighSierra beta GM) with your information. Many Thanks!!


#5

That’s good. Can you tell me how you got the GM version? If I use the download link on the developer site, for build 17A362a (the GM candidate), I’m repeatedly taken to the beta 9 page in the App Store. That’s build 17A360a, which I’m already running.


#6

I just re-access Apple Beta Software Program site, and download from the bigining as a first install, then GM build 17A362a was installed.


#7

Thanks, I had a suggestion from someone else too that solved the problem. My Applications had a previous version of the installer, and the App Store app was opening that one instead of downloading the new one. Deleting the older installer got me going.


#8

don’t wanna split hairs… but if I remind correct, editing the application binaries is prohibited by the lic. agreement…


#9

Ha! I wonder if there’s something in the license terms that implies that Trimble are giving you a working application?


#10

nope:


#11

I still won’t worry about it. The team could do the two character change to the master file, and post an update. Then the fix won’t be needed.


#12

I could get M3 today.
LayOut working fine with HighSierra beta !!

https://help.sketchup.com/en/article/141303


#13

Saves some hacking! My check for update still shows me as being up to date, no M3 offer for me, so I’ll stay with my hack for now. Not that I’m a Layout user…


#14

Although there isn’t yet an Update notification in the current version of SketchUp, there is a newer version over here:

https://www.sketchup.com/download/all

It gives you 17.3.116, and LayPut works ok.


#15

Thank you so much for this! My work stopped completely when I updated to MacOS High Sierra 10.13.1 (17B48))
Sketchup 2017 crashes when clicking the layers panel (haven’t got around that)
Tried to launch layout but it crashes immediately.

At first I didn’t have a clue you were talking about, but I was desperate so I downloaded a Hex Editor for the mac at
http://ridiculousfish.com/hexfiend/

Then I opened the Layout exec file. (applications > Layout > macOS folder > Layout exec
copy pasted /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/libruby.2.0.0.dylib
changed the numbers to /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/libruby.2.3.0.dylib

Saved the file

Then Layout 2017 worked fine!


#16

Why didn’t you simply get the latest 17.3.116, which addressed this problem?


#17

Thanks for the follow up. As slbaumgartner mentioned, the fix did get out there in the end.


#18

ok, please talk to me like you were explaining this to your mom.
what do I do to make Layout work on High Sierra 10.13.1?


#19

What version of LayOut are you having trouble with? If you’re running the 2017 version, then you should start by downloading and installing the latest version of 2017, which we fixed up specifically to run on High Sierra. It can be downloaded from this link:
http://dl.trimble.com/sketchup/2017/en/sketchuppro-2017-3-116-90851-en.dmg

Alternately, we just released our new version (2018), so you could download and install that if you have paid for maintenance & support.

-Marc


#20

Is there a suggestion that if I upgrade to High Sierra, Layout 2018 will stop working? I really need to know that as I was on the point of upgrading and I won’t do it yet if it scuppers LO.

Anyone?