SketchUp Pro 2017 opens but not Layout on MacOS Catalina

My wife has a Sketchup Pro 2017 license and until recently had no problem opening Layout 2017. But recently when she went to open it on her Mid-2014 15” Macbook Pro she got a message saying “Layout cannot be opened because of a problem. Check with the developer to make sure this version works with macOS. Be sure to install any available updates for the application in macOS.” The only thing I can think of that has changed since she last open Layout is that I updated her to macOS Catalina. Has anyone else had this problem [I’m assuming yes] and can you suggest how I might fix it. It appears to be impossible to get any customer support from the developer. Thanks in advance

LayOut 2017 does work ok for me in Catalina. It could be worth reinstalling. Download the SketchUp Pro 2017 Mac OS disk image from here:

https://www.sketchup.com/download/all

Make sure SketchUp and LayOut are closed, and drag the SketchUp 2017 folder onto the Applications alias. When asked, let it replace the old one.

Because Catalina won’t run 32 bit apps anymore (while Mojave can), that’s a reason not to update past Mojave if you rely on any legacy 32 bit apps. PowerCADD is one in my case. Right now, using the Mojave installer is a problem too.

It is SketchUp 2017 that they use, which was only ever 64 bit.

I did this several times but no difference. Sketchup and Style Builder open without issue. Layout cannot be opened. Are you suggesting I completely uninstall the software and then reinstall it again? Because what I’ve been doing is updating from the latest download and replacing the old files at the prompt with the new files… okay I did that too and still no dice

Can you post a screenshot from the app folder?
And or the dock?
How do you open LayOut? (Eg. Double clicking on a LayOut file, send to Layout from within SketchUp)

Layout 2017 doesn’t open for me either in Catalina:

Layout2017error

If you look at the report, Ruby 2.0.0 is missing:

Dyld Error Message: Library not loaded: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/libruby.2.0.0.dylib Referenced from: /Applications/SketchUp 2017/LayOut.app/Contents/MacOS/LayOut Reason: image not found

You might be able to symlink it to Apple’s installed Ruby at /usr/bin/ruby but you’d have to turn off SIP (System Integrity Protection) and mount the boot volume with write access (it’s now normally read-only).

I don’t need Layout 2017 as I have newer ones, but is this the same error you’re seeing, @Stuartc? Click the Report button to see.

Layout 2015 and 2016 opened ok here, so if you still have those, that might work for you.

That version of Ruby isn’t on my Catalina either, but no problems with LayOut opening.

One test worth a try would be to to paste this into Terminal, and see that output you get:

/Applications/SketchUp\ 2017/LayOut.app/Contents/MacOS/LayOut

Use Ctrl-C to stop LayOut.

When launched from the terminal the GUI error is the same as before, and in the terminal:

dyld: Library not loaded: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/libruby.2.0.0.dylib Referenced from: /Applications/SketchUp 2017/LayOut.app/Contents/MacOS/LayOut Reason: image not found Abort trap: 6

I didn’t edit the output this time, that’s everything.

I thought the Layout API started with 2018 so I don’t even know why it’s required.

I tested with 2016 to 2020, for me, none of them try to access Ruby.

That is quite strange. I probed the installed version of SketchUp Pro 2017 on my mac (Catalina 10.15.4) using objdump and could find no indication that Layout 2017 uses any Ruby dylib. For some reason it references the RubyDialog framework, but I checked that and it also did not reference libruby. SketchUp does load libruby, but uses a copy embedded in the app bundle, not the system copy, and it uses 2.2.0, not 2.0.0. This suggests to me that something is messed up in your installation of SketchUp 2017. I’d delete it altogether and then try a clean reinstall, not relying on the installer to overwrite everything cleanly. Be sure to get your license info first in case it is lost or damaged during the install!

I checked with the lead LayOut developer, and he asked to check to make sure that it is 2017.3 that you are using. Installer DMG should be called sketchuppro-2017-3-116-90851-en.dmg

2 Likes

Thanks @colin, upgrading from 17.2.2554 to 17.3.116 fixed it for me. I’ve only upgraded to Catalina a couple of days ago and I’m still looking for problems.

1 Like