A couple of problems with a simple shape

I have used Sketchup for a few projects, but it’s been a while. I just d/l the latest version and drew a simple object. I need to get it in STEP format ultimately.
In the process of trying some tools for that conversion, it seems that this shape doesn’t render properly. There are surfaces that should not be there.
I have also used FreeCad before, to convert between formats. For some reason it does not work for this shape (wrl to step).
Can anyone help me understand why it appears that this shape exports incorrectly? And then how to convert it to a STEP file?
I know that SketchUp used to be buggy when drawing small things (in mm scales). This part I drew is on that scale. I wonder if that could be part of the problem? In the older version I got used to drawing things at 100x scale, then scaling down before exporting, and that worked pretty good. Should I still do that?
Thanks in advance.
DanWide Terminal 121619.skp (94.0 KB)

What version of SketchUp are you using? Please complete your profile as that information helps us help you.

The only thing I see that might be a problem is an internal face where the end tapers down.

You’ve modeled this with Units set to meters so it would be difficult to check your dimensions. It would be easier to work on something this size if you set units to Millimeters.

As for getting it into SolidWorks, you should be able to just export a 3D DXF, DWG, or STL file from SketchUp and import that into SolidWorks.

Thank you - not sure if that internal surface was an issue, but your comment about units solved the problem. I changed my units to mm, then exported and it was all good. So mental note - set units smaller rather than larger! Thank you.

You’re welcome. Maybe the mental note should be to use units that are appropriate for the size of thing you are modeling. :wink: