Converting files to STL's cleaner

I’ve been recently having issues with my Sketchup exporting a geometry to an STL. it seems that no matter how simple or complex my geometry, regardless of size and scale, the STL’s I generate from Sketchup export as super faceted, much lower resolution, and significantly smaller than their original model.

I’m checking these STL’s by taking my Sketchup generated model, exporting to STL, then importing that STL back into Sketchup. I’m supposed to be using these STL’s to 3D print, however they frankly look terrible and would not result in a quality print at all. I’ve 3D printed other (very complex) geometries from Sketchup before, using Sketchup generated STL’s I exported, and they looked much better. This is a recent issue and I have no clue why it started or what changed between the first time I used Sketchup for this purpose (1 month ago) and now.

I was originally having issues with this and a complex geometry I was exporting, and figured it was just Sketchup having trouble handling a complex geometry, however after investigating, it is happening with geometries of all levels of complexity . See below for an example. In the example, I took a part I want to 3D print, exported to STL, and then immediately imported the generated STL back into the model. It is an extremely simple geometry (washer), but its still the completely wrong scale and looks like ■■■■. Yes, I tried scaling the part and using more lines when i make my curve. No, it makes no difference. Same issue. Everything was still faceted, full of holes, and spit out an unusable STL file. Sketchup_STL_example.skp (105.1 KB)

Am I just completely missing something simple? Is there ANY way to export files out of Sketchup better? There has to be…

As I told you in your other thread, if you want smoother curved surfaces you need to model with that intent. Also as I wrote and showed in your other thread, the STL file format simply creates triangles between vertices. You can see that in your model, too. You’ll get smaller triangles if you model so the vertices are closer together. Instead of making the initial circle for your ring with the default 24 sides, increase that number.

You’ll also find that it’s easier to work that way if you model with the units set to meters. So for something that is 1 inch long, make it 1 meter. The stl file is unitless so you should be able to tell the slicer that the file is in inches and there should be no problem.

After we finished that thread I went and generated this washer past at 1000x scale (not in meters, so I’ll try that next time) with 360 lines instead of 24. That STL export/import was the same, just with more holes in the mesh because it made triangles from 360 edges and not 24

Did you check to see that a group or component made from the geometry was solid?

yes, and with solid inspector

As far as the size - export and import using the same units. I would recommend always exporting using millimeters for compatibility with slicer software.

There is an option to the importer to “Merge coplanar faces”. It will be slow on a complex import but will go a long way to cleaning up coplanar faces on an imported .stl.

You can also use Thomthom’s Cleanup extension which has more options which are useful for .stl files.