Strange Artifacting on surfaces around curved edges when exporting SketchUp modles to STL

Hi, has anyone else had this issue when exporting STLs from Sketchup?

When I export a model as an STL from Sketchup 2017 and then open it in Cura there are all these strange faceted rendering errors on surfaces around curved edges. What is really irritating is that they get interpreted by the slicer as actual geometry and included into the final print.


For comparison here is the model in sketchup:

Does anyone know how to stop this from happening?

Share the .skp file so we can see what you’ve got.

Better to share a .skp file of the model not just a screenshot.

The “strange faceted rendering” suggest me to think there are really a separated (non coplanar) faces - where the bounding edges are softened/smothed in your Sketchup model.


By nature the STL file format consists entirely of triangles so it is no surprise that they are visible when the file is viewed. If they show in the finished actual 3D print, it would indicate that the surface that should be flat in the model is actually distorted. What does your SketchUp model look like if you turn on Hidden Geometry?

I’m not seeing those in the slicer when I create a .stl file from the file you shared.

Maybe change the model units to Meters and export the .stl that way.

Hidden geometry shows the individual faces of the curved services i created but nothing on the flat surfaces.

Hmm, maybe the issue is with Cura.

Or do you think the way I’m modelling at x1000 scale and then scaling down for export could be causing it?

However the file you shares is an .skb (a backup file) not an .skp… newer mind:

I also do not see problems in my export…

Conduits Share.stl (480.9 KB)

It’s probably because you are scaling down before exporting. Don’t do that. Set the model units to meters and export the .stl as meters. Import as millimeters. STL files have no units.

Your model in SketchUp. I only changed the units to Meters.
Screenshot - 11_25_2023 , 2_03_12 PM

And the imported file in the slicer.

That seems to have fixed the issue.

Thanks for your help!