STL Export reversing all faces on only some objects

I have three small objects, scaled down to mm from an original in metres for 3D printing.

Whenever I export the mm sized ones to STL, two of the three objects have all their faces reversed.

Here’s what the original SKP file shows:

And the STL imported back into SU:

Notice the extra line introduced in the rear part, top right. If I delete that line, the face disappears, and drawing a rectangle corner to corner normal to the green axis won’t recreate it.

The Mac Preview viewer shows the same face reversal.

Here’s the original SU file.
Trammel parts.skp (878.7 KB)

I can fix it for printing by reversing the faces in the two outer parts before STL Export, but why is it happening in the first place? The original parts are all solid according to Solid Inspector 2, and their component axes are parallel to the overall model axes.

(BTW, the file is purged, but not shown in the images are other parts which won’t be 3D printed.)

Is this a bug in the STL exporter, or some quirky feature of the way I drew the parts or scaled them?

I’ve occasionally seen this sort of behavior with very small parts. Can’t say I ever worked out why.
These days I work in meters and just tell the stl it is mm. So the original SU file stays as meters, no scaling needed.

STL export treats everything as ‘raw’ geometry…

it attempts to define single objects by ‘assigning’ inside/outside to ‘all connected’ sets of geometry…

it is the same reason conjoined components or wall thickness in hollow solid works…

however, I suspect the small sizes is breaking it’s ‘solid’ logic…

as box says, use meters and it will ‘see’ separate items…


Thanks for your comments.

I’ve tried that. I use Lulzbot Cura to drive my 3D printer, I draw in metres in SU, then tell the SU STL Exporter to use mm as units, but it still comes in to Cura 1000x too big. I can scale it down in Cura, though it isn’t quite as convenient, so perhaps I should try that route routinely instead of scaling a copy of the components down in the SKP file before export.

Indeed, Cura may not even care about the reversed faces - I should try that too.

None of the edges, not even the bevelled corners, are less than 1mm, so should be well above SU tolerance levels for ‘small edges’, I’d have thought. And wouldn’t the effect, if there is one, be that of not creating a face, rather than reversing all faces on just some components?

I know there are workarounds, and I’ll use them. Just thought it was (a) puzzling and (b) worth noting, in case it’s a fixable bug in the exporter.

it’s ‘solid’ logic

I was referring to the exporters conversion of raw geometry to it’s concept of an stl ‘solid’, not SU’s native logic…

you would need to look at the code on github to see what it’s doing…


A good thought, but I’m not a good enough programmer to make much sense of it, unfortunately. I’ll just keep using a workaround.

I don’t see this as a SU issue. I use Simplify 3D and have the random reverse face thing occur also. The face size doesn’t seem to be a factor. I will have a model that looks good, all solid, etc, but when sliced some surfaces are not there. I simply reverse those faces. Looks wrong in SU but slices fine. I find slicing software generally is random in accepting solids that are no solid, and also loosing faces sometimes as well. A bit frustrating when the model is drawn perfectly well but simply won’t work in that form.

So far, so good, with the wholly reversed faces on two of the three objects. The Cura slicing and printer control software seems not to care about the reversed faces, and has printed all the pieces. All print fine in a test print. Have to adjust the dimensions slightly to get the slots and holes just the right width or diameter, to allow for the thickness of the filament, and will reprint, I hope final size, shortly.

Doesn’t SketchUp 2018 and above have a native STL exporter/importer? I don’t see the reversed face thing using the Ruby extension in SU 2017.

@john_mcclenahan which STL extension are you using?

1 Like

The one built in to SU 2019 Pro (desktop).

Did you check for the reversed faces in some other application after exporting? I just wonder if they got reversed when importing them back into SU instead of when exporting…

Yes, I did. Mac Preview showed the faces reversed too, in the exported STL file.

And it turns out that the Cura slicing software doesn’t seem to care that all the faces were reversed - it printed them just fine.