3dwarehouse blank pages in IE

Just a heads up.

Your entire site:
…shows up as almost completely blank pages in Internet Explorer.
No 3D, no text, nothing, just white pages with some logos and a few lines and borders.

Im using IE 11 and Win 8.1 Pro.
Everything is updated, and i tried clearing cache etc

Works fine on Firefox and Chrome on the same PC.

Oh, and also:
The site looks fine when its opened from inside the sketchup-program.
That uses IE for rendering right?

Yes, inside SketchUp on PC, it uses IE for rendering. Checking on it. Thanks.

We’ve tried your configuration and a few others (Win 8.1, Win 7) and we’re not getting the error. Is it still happening for you? Where in the world are you located? We’ll try to visit our site from a browser near you.



It seems that there have been problems with IE 11 with some sites. I may know of a possible solution.

First, you will need to clear your cache on IE 11. The most effective way to do this is to close all browsers, then click on your ‘Start’ button and select ‘Control Panel.’ In the Control Panel, select ‘Internet Options.’ Remaining in the ‘General’ tab, select ‘delete’ under the browsing history heading. Make sure all of the option boxes are selected with the exception of the first option of ‘Preserve Favorites website data’. Finally, select ‘delete’ and wait for the process to finish.

Once that is done, open IE 11 and select the ‘Tools’ menu. There should be an option that says ‘Compatibility View settings.’ Click on that, and add https://3dwarehouse.sketchup.com to the site list. You will notice that it will only add the actual domain of sketchup.com. Close your browser and re-open it. That should allow the page to be loaded. It worked for me.

If this doesn’t work, please feel free to contact me. I am happy to help. :slight_smile:

Nope, makes no difference.

And i also noticed that often when i open your site in IE, the tab and the browser cant be closed.
I have to use taskmanager to kill it.
No error-messages or popups, just no reaction to clicking close.

Also something have never seen before.

Let me do some testing, and I will see if I can come up with a solution for you.

Another thought I had, do you have any browser add-ons for IE? This can cause some of the behavior you’re describing, but it can be tough to track. Try running IE without add-ons. If it works, then we know that there is an add-on causing the issue.

from Start> Programs> Accessories> System tools> Internet Explorer (no add-ons)
If the problem goes away, you have an incompatible browser add-on installed.

Nope it s completely clean.

I only ever use it for testing if things work in IE

And now i have reset it too.


“Start> Programs> Accessories> System tools”?

No such thing in Win8

Do you perhaps use Win7, and never test things in Win8.

Aaand hang on, i just discovered that the site works if i First start IE by right-clicking and running it as administrator.

Thats a first.


Mats Svensson

Tel Hem: 046-390949

Tel Mobil: 0706-390949

You are correct. I was using the wrong computer. Apologies. I can test in Win8 if need be, though I am not a fan. Admin was my next suggestion, though you will have to configure the program to always open in admin in Windows 8:

1.Go to the location of the executable.
2.Right click AppThatRequiresAdminRights.exe and select Troubleshoot compatibility.
3.Select the option Troubleshoot program after the wizard has finished detecting issues.
4.Choose the The program requires additional permissions option. The wizard will apply the Run as Administrator setting to AppThatRequiresAdminRights.exe program.
5.Click Test the program (required) and close the wizard

Yeah, but…

Since i use IE for testing, I always try to keep it running as close to out-of-the-box as possible.

Good luck telling visitors who wants to see a site, or embedded content, that they need to “run IE as admin”. =0


Mats Svensson

Tel Hem: 046-390949

Tel Mobil: 0706-390949

So that’s the question. I wasn’t Admin on the Win8.1 IE 11 machine. If this fixes your issue, it’s not meant as a solution for everyone: it’s meant as a clue to figure out how yours somehow broke.



Another option is to clear the DNS cache on the computer, which sometimes helps when clearing the browser cache/cookies doesn’t do the trick:

Any fix for this?

I completely forgot about this, until came to your site again today.
Still broken!

Still the only site I can remember seeing in this millennium, that doesn’t work on IE.

Maybe you should get one of those oldtimey “This site best viewed with browser x”-banners and hang all over the place?

We test from IE 8 - 11 including IE 11 and Win 8.1, and it works on our test machines. We don’t need the banner because it’s not broken on all computers, but it is on yours. If I can reproduce it, I can get it fixed. But I’ll need more information. You can break this via IE settings. For example, if you set internet security to high in IE. You say you test in IE? What do you test and what are your settings?

Could you private message me https://3dwarehouse.sketchup.com/debugging.html results?

I have this same exact issue as Mat but my OS is Windows 7 however none of the previous suggestions worked for me either. No joy on googling this issue as it appears I’m the only one with this problem.

  • Chrome works perfectly fine but IE 11 or within Sketchup won’t load 3dwarehouse.sketchup.com (Blank page with a few visible frames)
  • Added sketchup.com to Trusted Sites and set security to Low - no luck
  • Cleared DNS cache - no luck
  • Ran IE as admin - no luck
  • Temporarily disabled Norton antivirus - no luck
  • Extension Warehouse works perfectly fine in IE!!

Were you guys able to come up with any sort of solution?