3Dconnexion SpaceMouse setup

mac
spacemouse

#1

Are there any SpaceMouse users out there who could lend a hand? I have just taken delivery of one and am finding it hard to get set up.

The first problem is that I get a message telling me that I cannot use the trainer as the software has not been optimized for Mac. Looking online suggests this problem has been unresolved for at least 6 months.

I have managed to set the Sm up for use with Sketchup using default settings. But all that happens is that it behaves much like any other mouse, controlling the cursor position. What I want is for it to control the camera. DoI need to change default settings? If anyone uses their SM this way, it would be great to know what settings are being used.


3Dconnexion SpaceNavigator not working with Sketchup Pro 2018 on Mac
#2

And now this dialog box has popped up automatically. I quit some applications but now the box won’t close. As that hasn’t happened before, I assume it has something to do with the SM. Aaaagh! The rodents have taken over.

16


#3

I will have a look later, all I know is that I have had never ending issues with it on PC to the point where I have not completely wiped it and only using it on my Mac with occasional errors.


#4

Thanks. It looks like you can export and import configurations so I guess my ideal would be to find someone using their SM for camera views and simply import their configuration, even if I find I have to tweak it later for my own use.


#5

I have been mining to a new laptop and installed my space mouse. First try it was behaving just like you said. I re downloaded the most recent driver, reinstalled, rebooted and it worked. Not sure why I had this issue with my past two computers… just glad I got it working!


#6


#7

Thanks Aaron.

One of the first things I had to do after connecting the SM was to download the driver from 3DC website. So it should be current, shouldn’t it?

I have it connected to my keyboard but wonder whether it needs a powered USB socket?

Since installing it, the Force Quit dialog box keeps popping up and then closes SU automatically. Very weird.


#8

Mike, are you suggesting that installing my SM could have an effect on one of my BMWs?? Yikes!


#9

On my current computer, when I first installed, I was running through a hub, and I seem to remember that causing an issue. You may try running directly to eliminate that as an issue. I would recommend a reboot/reinstall/reboot if that does not work.

At that point, try reaching out to 3dconnexion. They are responsive and very helpful!


#10

The memory issue was mentioned by @slbaumgartner some two weeks ago?
Though he has found a workaround, by restarting, I to had issues with the 3D when working on a Mac(book),on a iMac, I did not have them, though…


#11

Judging by this thread, I’d say the SM is the cause of my memory leak: MacOS Sierra 10.12.4 Memory leak.

I did rather fear that investing in a SM might raise quite a few teething troubles. As things stand, I have a SM that does nothing but move the cursor around in a rather less manageable way than my regular mouse and a memory leak problem. Oh the joys of tech!


#12

Interesting! Maybe that’s because you work for SketchUp/Trimble? They have never responded to anything I sent, including multiple postings on their forums about the memory leak issue. I have seen multiple posts by others who also got no satisfactory response from 3DConnection. If they are as helpful as you say, I can’t understand why they are completely blind to this issue despite it’s being reported now for several years.

A few years ago (don’t remember which SU version), the startup process on the Mac was changed so that the default empty model window is opened before the Ruby extensions are loaded. If I recall, this was to avoid issues with extensions that looked for an active model or tried to add icons to the custom toolbar as they loaded, before one had been created. But I think it had the opposite effect on the 3DConnection drivers, causing them to become totally confused and to grow without limit. My workaround of closing the default window before Ruby gets a chance to load supports this theory.

Let me be clear: I love my Space Navigator and have become completely dependent on it. It’s frustrating to have an obvious issue be out there for so long.


#13

Steve, I did get quite a quick response from 3DC to my query (as below). Sadly, it is the usual standard response along the lines of “did you remember to plug everything in?” I have replied and we shall see how far they are willing to go in troubleshooting. I am sure I must be able to get it to work if it works for you and others. It’s just a question of finding the right settings and sequence of installation operations I expect.


#14

Reading various posts, the solution some have found to the memory leak is to get used to shutting down the default blank SU window that opens on startup. That is not working for me as SU often opens the last file I was working on. Looking at the Activity Monitor, I see that “kernel_task” seems to be taking the lion’s share of the memory. Mind you, I only have the vaguest idea of what I am looking at really! If it is taking over 1 GB when everything else is using a fraction of that, I conclude it is hogging the memory.

I am a bit worried that posts seem to suggest this is a longstanding issue that 3DC don’t ever seem to have got to grips with.


#15

Around 1GB more or less is a fairly normal amount of memory used by the kernel task, not an issue.

When it runs away, the 3DConnection issue rapidly causes SketchUp to consume memory without limit. Since all modern computers use virtual memory management, this can actually be far more than the physical RAM in your Mac! The result is what is called “thrashing” in which the memory system expends all its effort reading and writing contents from and to your disk, which both vastly slows down the computer and eventually causes it to crash.

Just for jollies, I submitted a ticket to 3DConnection. Not optimistic about getting a useful reply, but we’ll see…


#16

Yes, let’s see.

I know it’s barking at the moon really, but as an end user and not a techie, I get quite frustrated when manufacturers seem to expect you to get under the bonnet and tweak things. I don’t expect to have to adjust the settings on my carburettor before I can drive my car! Not that many cars have carburettors any more. Or so I hear…


#17

I know that I have said this before (not trying to sound like a broken record) but a reinstall fixed that problem for me, as well. Not sure if there is some sort of issue with their installer, but installing it over the top of itself helped with a bunch of problems.


#18

Aaron, I hadn’t picked up that you meant reinstalling the same thing. I will try that now as I have uninstalled the driver in case that was causing the memory leak problem.


#19

For sure get latest driver and reboot.

also from an old thread:
did you turn it on??

in SU >> Preferences >> Extensions…

and make sure Sketchup is Selected in System Preferences…

sounds like its not configured for sketchup…as the SM will work in other apps just like a regular mouse.


#20

Simon — I’ve had a SpaceMouse for about 4 years now, running on MacOS (currently on el Capitain 10.11.6). Persevere in your efforts, since a (working) 3D mouse is the biggest single boon to SU productivity.

I’ve had the memory leaks that you describe. Steve’s fix is one way to avoid the leak, but there’s another condition that seemed to cause it for me: 3DX installs the plugin in the root drive library: ‘MacintoshHD/Library/Application Support/SketchUp 20xx/Plugins/’

If somehow you also have it installed in the your home directory (the usual install location for SU plugins), then it seems to cause the same memory leak.

I would check then to see if there is a duplicate copy in ‘MacintoshHD/Users//Library/Application Support/SketchUp 20xx/Plugins/3DXSketchUp’ and erase both the launcher file (.rb) and the folder for the plugin.

Hope you get it sorted, one way or the other.