SpaceMouse settings problem

Ive just realised how badly my SpaceMouse has performed over the years - its probably my most expensive unreliable piece of hardware sucking power sitting on my desk at the moment. Its only gotten away with this as it looks and feels so nice.
Anyway, my question is how I can get the setting to stay and work without having to constantly reconfigure. Even importing the saved settings doesnt work.
I suspect its a typical hardware usb or windows conflict or something tedious. Just want to get on with my work.

I use a wired SpaceMouse. I do find that it occasionally loses its settings for no apparent reason and then I have to download the driver and reinstall. Which is a pain because you have to keep the firewall open when you do it. But mostly it’s pretty well behaved. Mind you, I use a Mac and you use a PC.

- Uninstall the current driver from your machine by going to Control Panel.
- Once that done, please do steps 2,3,4 in our FAQ here https://www.3dconnexion.com/faq/1100
- Reboot your machine
- Reinstall the current driver from our website https://www.3dconnexion.com/service/drivers.html
- Reboot your machine
- Test it

Thank you for the logical advice which seems very sensible. However after following the cleaning out and reinstall proceedure it still doesnt work in Sketchup (Pro 2020) - the 3Dconnexion test tutorial is fine with expected performance though. Its just rubbish with SU.
BTW it would be helpful if the install window had the Remove old settings checked as default!
3dx

The 3dConnexion drivers are not yet aware of SketchUp 2020. You have to copy the extension files manually to the required place. Search the forum for other recent posts describing exactly what to do.

They do install on the Windows platform without extra help other than the right click trick.

Did you right click on the downloaded file and choose “Run as Administrator” ?

Thanks for your hints gentlemen/ladies. Just to clarify, the drivers install Ok, its just the resulting performance/actions are rubbish. As the 3D not being aware of 2020- thats outrageous!!
In the meantime its quite a nice paperweight

Try deleting the paperweight in the settings for the universal receiver and re-pair it. I have also found having the receiver in a port instead of at the end of a USB cable helps.