3Dconnection spacemouse

My 3Dspacemouse is suddenly not responding anymore in Sketchup (windows 11, Sketchup version 22.0.354 64-bit). Outside SketchUp, it works fine, for instance in the default viewer of 3Dconnection, or the 3D trainer. I tried to remove/reinstall the 3D driver, but no luck. Windows is fully updated, and the drivers are up to date,… I saw online that people were speaking about an entry in the application manager, but I can’t find if this is still valid. If it is, well I can’t find it in the store :slight_smile: Suggestions, hints are appreciated. O, yes i tried also rapair the Sketchup installation, no effect.

Did you download and re-run their latest installer?

https://3dconnexion.com/us/drivers/

yep, did an remove and reinstall (with the latested driver) and a laptop restart after removal en again after install

Did you disable your firewall prior to installation?

I did not disarm/disable my firewall prior to installation of the driver. I do not see the need to to so. The spacemouse is functional, in the 3dmouse software it reacts well (trainer, game etc). Only in in Sketchup it seems not to register.

OK. I only use my SM for SU so I am not sure whether the need to disable the firewall is relevant to you. But I couldn’t get my SM working without doing that. Obviously, you only need to open it for the few minutes it takes to get the SM registered, then close it again. Might at least be worth a try if nothing else has worked?

I will try it (when I’m home again, currently a week off [yeahhhh] without a laptop in site :joy:)

What operating system are you using, Windows or Mac? This can allow a more straightforward solution to the issue. Please update your profile.

RLGL, my profile is up to date. Beside my profile, in the post I mention I use windows 11 (cpu/gpu also clarified) what more do I have to add?

Your profile lists: Operating System as : MS11 (12th Gen Intel(R) Core™ i7-12700 2.10 GHz). Replace that with Windows and its version.

What they have given in their profile is actually a bit more useful than Win 11.
It is telling us it is windows 11 and a fairly slow processor.

I never was good at reading between the lines.

1 Like