3Dconnexion SpaceMouse setup

Good point!

It’s not obvious to a new user that you have to install the plugin from this pane of the 3Dconnexion Preference window:

I don’t seem to have an Extensions option under SU/Preferences:


I agree that it doesn’t seem to be configured for SU and yet I thought I had set it up for that.

He is talking about the Extension Manager… Not SU preferences…

That is interesting. I installed it in the way the Quick Start guide suggested by using the 3Dconnexion Home panel (Properties). However, I thought I’d try your way and the installation process does seem to be slightly different (and much faster). BUT…no difference to the way it works in SU.

I will persevere, partly because everyone who has successfully managed to install say the device is a wonder and partly because I shelled out a shedload of money for it!

Like this?

Looks OK to my uninitiated eye.

Just asking because I have not heard, have you restarted your computer after installing?

Yes, Aaron. I have now installed in various ways, shut down the computer and restarted it 2 or 3 times but the SM is proving reluctant! And the memory leak problem persists too. [sound of teeth grinding!]

I am not sure where the plugin installed itself. If I do a search for 3Dx I get this:

That top one on your extension list (3DxSketchUp) is the one. Looks like things are OK on SketchUp’s end…

Yes, it appears in Extension Manager as you would expect and the search suggests there are no duplicate copies. So I guess it is over to 3Dconnexion. Let’s hope I get something from them.

I thought I’d try looking for a software update (I know - clutching at straws!). I get this message (which I also got when I first tried to install). Can’t help feeling this might have something to do with it.

That just means it is a 32 bit application. You can pretty much ignore this at the moment. Apple is trying to move everything to 64 bit, but even some of their own apps haven’t been updated yet.

Oh, right.

Do you think this means anything? Looks like the software doesn’t realize a SpaceMouse is connected. That would explain a lot.

I see that 3Dconnexion actually have telephone support numbers. Lines have just closed for the day but I shall see if I can reach them tomorrow. If I get success, I will update this thread as it may be useful to others. Usually problems seem to arise after something else has changed like an updated OS or new version of SU. I didn’t think getting a brand new device to work with an OS and CAD software that have had time to bed in would be such an uphill struggle! Never mind, I’m sure it will all be worth it in the end.

Do you have it plugged into its own port? this might eliminate conflicts in a hub or the like?

I started with it plugged into one of the USB ports in the side of my Mac keyboard. Then it occurred to me that it might need a powered socket so I plugged it into a hub. I presume by “its own port” you mean directly into the back of the Mac? I haven’t tried that.

I’m willing to try anything but I can’t help thinking that if it was that sensitive, the manufacturers would make it clear that it must have a direct connection. I presume there must be some people out there who buy a SM, plug it in, and just go. One day, my prince will come…

Does it light up when plugged in?

I’m not on a mac so can’t advise specifically, but I would say worth a try as sometimes it can be an issue. At least it would eliminate a possible cause. It might be that if it configures this way that you might then be able to move it to another port? Not sure which SM you got, but it looks like it may require power as mine lights up blue.

Yes, and it moves the cursor around, so clearly the Mac knows it’s there. What is missing is any special connection with SU that allows it to be used for navigation.

That and the irritating memory leak problem.

I have now tried it and it doesn’t seem to make any difference. It works the same whichever USB port I use: back of Mac, powered hub, or keyboard port. The mouse (SpaceMouse Compact) lights up and moves the cursor around, so it’s by no means dead.

that sucks, very frustrating. Like I said I don’t know how it configures on a mac, but it should configure to the respective program it’s used in. If…when you do get it installed, this is how I have mine set up.