3D warehouse not working or loading in 2024 version

I am not able to load 3Dwarehouse all of a sudden. it was working till last night. I have even tried opening the file in the 2023 version and the same thing happen. I have tried to access 3D warehouse via toolbar and via windows tab.

It is working with my set-up at 10:30 EST on 2024-05-08.

I had to sign in with SU 2024 to enable the use of the 3D Warehouse.

1 Like

Hi @kriti.terway thanks for the post. I ran a quick test and it looks like everything is working on our end at the moment, can you post a screenshot of what you are seeing if you are still seeing the issue? If you are and we get a screenshot I’ll go over to the 3D Warehouse team and see if they have any ideas.

I also tried to recreate the issue using SU2024. It worked fine for me. More details would be helpful.

This is usually a network issue at your home or school. We’ve covered this a bunch over the years:

The fastest way I’ve found is to use Google DNS (as suggested in the thread above) but only if you have rights to change it on your computer. If you do not have rights to do that, contact your IT Dept and ask them to TRY using Google DNS to see if it fixes it. To learn more, google “Google DNS servers”.

This started happening to me too. No issues in the 2022 or 2023 version but since 2024 I am having this issue. 3D Warehouse just stopped loading, as in nothing happens when I click the button(s) in SketchUp to load it. If I click the button too many times, SketchUp will crash. I can still load through a web browser but this isn’t efficient when importing many new and different items. Tech support has not yet been able to help. They advised on deleting the applicable AppData contents and that did not help. Deleting and reinstalling did not help. Uninstalling SketchUp, deleting the AppData content and then reinstalling did work initially but after a short time, 3D Warehouse stops opening. All other similar functions, like location features continue to work. Any advice from anyone?

1 Like

Hi Mike, I have been having the same problem with the warehouse for about a week or so now. I work from home and also at an office with different internet providers so I know for a fact it is not my internet connection as the Sketchup help person mentioned above. I re-downloaded the 2024 version with still no luck. If anyone can figure out what this is and how to fix it please let me know. Thanks

There’s something wrong with the google warehouse feature if people are having these many problems.

Google hasn’t had anything to do with SketchUp for more than a decade.

If this was a problem with the 3D Warehouse itself, everyone would have problems with it. Not everyone does have problems, though.

Paste this into a folder address bar
%appdata%/SketchUp/Sketchup 2023 (or 24 if that’s what you are using

delete the webcache folder

1 Like

I’m having the same problem setting up 2024 with plugins. I click on extension warehouse or manager and nothing happens - very annoying. I’ve checked firewall settings etc. and haven’t found anything that might stop Sketchep accessing the internet - presumably if it was an internet problem warehouse would at least open a window?

The windows are probably opening off screen.

Did you install SketchUp correctly? That means right clicking on the downloaded installer and selecting Run as administrator. If you didn’t or don’t know, close SketchUp and find the installer in your Downloads folder. Right click on it, choose Run as administrator, and then choose Repair. After it completes, do a cold reboot of your computer. Then try opening the Extension Warehouse. If that doesn’t work there’s another trick to try.

Please update your forum profile. It says you’re using SketchUp 2021.

Someone did report a 3D Warehouse issue in 2024, that was fixed by a change we made in the update posted today. It has other useful fixes in it, so you might as well update:

https://www.sketchup.com/en/download/all

DaveR

Repaired as admin
cold reboot
still not working

I’m using two screens - no sign of any Extension warehouse or manager windows anywhere.
Would appreciate any other ideas on the subject.

I seem to remember a similar problem from a few years ago where the embedded browser needed the presence of Internet Explorer to work correctly. Is this a contemporary version of that problem?

Thanks in advance.

Phil

Have you unplugged an external monitor? @DaveR suggested thewindow was opening off screen. Have you tried this:

  • type alt+space
  • type m
  • click an arrow key
  • move the mouse until the window appears

Annsi,

two screens running configuration hasn’t changed - nothing opening offscreen

Phil

Hello,
I have a similar issue with ADD LOCATION extension.
I tried multiple installation with the latest version.
Actually two days back with the previous last version of 2024 I could open add location.
From the following day not anymore.
I installed the latest version that already incorporate ADD LOCATION 1.5.9 by default but no luck.

Any idea?
Thank you
Stef

I’ve run into problems with people using VPNs of late

Hi steste77! Could you provide us with more context about this? You say it started not working when installing the latest version of Add Location 1.5.9, or that was before?

Thanks in advance!
Best,
Pablo

Hi,
I received the below answer from Tech support and now it is working correctly.

Tks for your help

Hello stefano,

Thanks for reaching out to SketchUp Support! I am sorry to hear you are experiencing this issue with SketchUp.

This error can come up when there is a conflict in SketchUp’s web cache. Please delete the WebCache folder so that it can reset. You’ll find the folder’s pathway below.

On Windows: C:\Users<USER NAME>\AppData\Roaming\SketchUp\SketchUpXXXX\WebCache

On Mac: Finder> Go> Hold the Option key> Library> Application support> SketchUp> SketchUpXXXX > WebCache

2 Likes