3D Warehouse not loading on Sketchup 2017 Desktop app

I was in the middle of using Sketchup 2017 today (was several hours in) and the 3d Warehouse stopped working. I’ve been using this app for many months without any issues. So far I’ve tried the following to get it to work correctly again.
·Deleted and Re-Installed
·Deleted 100% Through Registry Editor & File Explorer then Re-Installed
·Recovered PC to yesterday
·Verified all Drivers and Software was up to date (Re-installing Visual c++ )
·Cleared Chrome Cookies and Cache
·Flushed DNS and changed IP address + Verify network settings
·Verified the Ports that Sketchup uses are open
None of the above have worked.
I did notice an Error when I inspected the 3d Warehouse element in Sketchup 2017 but I was unable to resolve the error. Error is: uncaught syntaxerror unexpected token… vendors 619a5ebf2.js:2 It is imaged below.

Another check I did was I signed up for the Sketchup PRO 2021. For some odd reason it works just like normal on Sketchup PRO 2021 desktop app. It also works fine on Sketchup Free (web) however I prefer the desktop app myself but I don’t need or want to pay for Pro. Does anyone have any other ideas on what I can do to get the 3D Warehouse to work correctly again on Sketchup 2017? My only next step is a 100% fresh install of windows 10 incase. Below are images of what I am seeing in Sketchup 2017 along with the error.

I also forgot to add, When I inspect the 3d Warehouse, There is an error code but I couldn’t figure out how to resolve it. Error is: uncaught syntaxerror unexpected token Vendors 619a5ebf2.js:2 (which has a link of https://3dwarehouse.sketchup.com/deploy/619a5ebf2/static/vendors_619a5ebf2.js )Picture below. Screenshot - 995f2307f5155ed13290062b0892386f - Gyazo

Having the same problem as GoodNight15. Did a quick search for similar posts from the past and as it turns out this happens every now and then. Just giving the devs a holler for a fix.

Thanks in advance.

I have the same problem and started in roughly the same time. I noticed it was down last week. I presumed it was a glitch in their system, but given it’s persisted through this week, it concerns me. I’ll try this on my home system as well.

You might see this:

Go here and download the ones you want and save them in a downloads file or similar, then copy the model into your work - work for me.

https://3dwarehouse.sketchup.com/?hl=en