3D Warehouse Stopped Loading in Sketchup 2020

3D Warehouse in 2020 has stopped loading in my Windows 10 PC.

I have already cleared the Webcache, ran a repair using the fresh install, and rebooted my machine. Co-Worker’s machines are all working fine without issue. I do not want to reinstall if I can avoid it as I have a bunch of extensions I don’t want to go about hunting down again.

EDIT 1: Downloading from a separate web browser adds extra steps to the project, so I’d like to do my best to fix the problem.

EDIT 2: I reinstalled Sketchup and the Warehouse still doesn’t open

Is there anything else that might work here?

A simple forum search reveals many threads about this topic, among them:

Yes, and I’ve tried all them all. None of them have worked. So I started my own in the hopes someone had a new method or idea that hasn’t been posted yet.

Also, the issue the person is having in the link is not the issue I’m having, mine is just blank

How blank is it? Are there any icons in the upper left of the window? If there is a house icon, what happens if you click on that?

Right-click in the empty window, and choose Show DevTools. In the window that appears, choose the Console tab, and show what errors are appearing there.

1 Like