3D warehouse for Sketchup Make 2017

I’ve been using SketchupMake 2017 for quite a while now. I’ve always been able to use the 3D warehouse until recently. The problems started a while back when it started demanding a user name and password. tried to enter those, but it wouldn’t recognize me. Now when I try to use 3D it just opens an empty page with no content. HELP PLEASE!!!

It’s been more than a year since the 3D Warehouse stoppped supporting SketchUp 2017. This has nothing to do with requiring a username and password. It has to do with SketchUp’s “Current Minus Two” policy. That means the current and previous two versions of SketchUp are the only ones the 3D Warehouse supports. You can go to the 3D Warehouse via your internet browser and download the Collada version of the models/components you’re after and then import the included .dae after extracting the contents of the downloaded zip file.

1 Like

Thank you. I don’t understand all of what you said. Do you have a link to the page where I can download the 3D files?

A simple search for 3D Warehouse will lead you right to it. 3dwarehouse.sketchup.com Search for the object you want, hover over the right end of the Dropdown button and then choose the Collada file.
Screenshot - 6_27_2022 , 1_45_21 PM

Or, as this must be a hobby for you, you could just model the objects yourself. :wink:

Thanks again, Dave. Yes, it is somewhat of a hobby. Right now I’m trying to design a log mill that I can use to cut some large logs into usable lumber.

Okay. I fund the page and did a search for a tire. It came up with a few options, but when I hover over it nothing pops up except the word DOWNLOAD Nothing like your photo and nothing about Collada files. And when I click the download I get the same thing I got before where it wants me to sign in.

You’ll still have to be signed in. Click on the right end of the Download button. There should be a dropdown arrow. Then choose the Collada file.
3dwh

1 Like

I don’t know what I’m doing wrong. When I click on the download I get the drop down you’re talking about but it still wants me to sign in. When I do I can get the .zip file but it says “This does not appear to be a Sketchup model!” Then when I try another file it want’s me to sign in again, And now it wont except my sign in user name or password.

Yes. Of course you have to be signed in.

As I wrote in my first reply:

You have to use Import, not Open.

Did you set up a Trimble account? You need that to sign in to the 3D Warehouse.

Click on the Sign In button and then create a Trimble ID.
Screenshot - 6_27_2022 , 2_36_50 PM

Yes, I did use my Trimble account. For some reason it keeps singing me out and I have to keep signing back in.
Okay. I’m signed back in. Now it wants me to start a 30 day free trial. I got the .zip file but when I try to open it I get the error message “This does not appear to be a Sketchup model!” And then it takes me to the free 30 day trial page again

Well, since signing in sets a cookie in your browser’s caches, it sounds like you’ve got things set so yuor browser isn’t saving your login.

AGAIN: Don’t open the zip file. Extract the contents and IMPORT the .dae into SketchUp. Thats File>Import not File>Open.

So, I think I have it figured out. I found the .dae file in my Download folder and I was able to import it, but it doesn’t look like the image in 3D at all. It imports some sort of a wire frame image. Also, I got the file from the 3D PRODUCTS category. Should I try one from the MODELS category?
I did extract the .zip file before I tried to import it.

Another option you have is to open SketchUp Free Free 3D Modeling Software | 3D Design Online | SketchUp Free Subscription

The Components Icon on the right gives you the option to search and add Models from 3D Warehouse
image

Then you can save the skp file to your device by using the Download option in the Menu at the top left

when you click on the skp option an option comes up for SketchUp 2017
image

You know what assuming does, put it this way you can’t do it without an ass.

Use File/Import then in the Import dialog choose the file type, Collada (.dae) and the navigate to the .dae file that you downloaded.
This will import a 3d model, not including an ass unless so chosen.

Oh, hang on, I’m talking windows, it will be similar but not the same on Mac.

Thanks
Yes I was being a complete ass thanks. I didn’t have my import set to collada and now I have successfully imported and scaled some great trees into my model.
Cheers
Graham

1 Like

I’m glad you saw the funny side of my comment, others may not have found it funny.