3d warehouse Failed to render... but not?

You could try empty caches in Safari, command-option-e

Hi @colin,

No dice. I tried with a different computer, cleared chaches, browsing history, everything.
Once logged in I still get the “Failed to render” message.

Testedon MacOS with:

  • Chrome: Version 106.0.5249.119 (Official Build) (arm64)
  • Safari: Version 15.4 (17613.

Test steps:

  • Clear caches, history, cookies, etc.
  • View the model details
  • Validate the model shows as properly rendered → yes it shows correctly.
  • Log in
  • View the same model
  • Validate the model shows with “Failed to render” → yes it shows as failed.

Looks to me like an issue that requires a bug to be opened.
What say you @TheGuz, @colin ?

Another example of the same would be: Interior design brownstone house | 3D Warehouse

I have the same exact issue. When I am logged in on the warehouse, some of my models has the fail to render message. But if I log out, or copy the embed code, it works fine. Other ones of my models also work fine. This looks like some kind of bug, @colin @TheGuz

These are the models:
the original second temple | 3D Warehouse (sketchup.com)
bed from the times of the Mishnah (updated) | 3D Warehouse (sketchup.com)

FWIW, I have no issues viewing the models in this thread.

I think it is only if you are logged in as the creator of the model, which makes this whole thing very strange.

Yes, I was logged in, but I am not the creator of the model.

@colin, @TheGuz,

Any insights into this? How do we get this progressed?

Spoke to @TheGuz earlier in the week, and he was going to get his team to look into the problem. Haven’t heard how that is going.

1 Like

Hi, @colin, @TheGuz,

Checking back in on this. Any feedback yet?

I see @TheGuz in meetings occasionally, including this morning. I sent a link to this post to remind him about the issue.

1 Like

Thanks @colin . I trust it will get resolved.

Hi Thomas! Apologies for the delay. I"m hoping this has fixed itself in the last 20 days. I’m gathering up the data to see if we can troubleshoot it. Right now I’m using a Mac (on Venture 13.0.1) with Chrome and I see things fine.

I just tested with Safari 16.1 and everything appeared as expected. If you wouldn’t mind trying it once more this week and I can dive into it deeper if things aren’t working.

To see if it might be account related, I signed out of my normal account and into two other accounts. Everything working as expected.

I just checked, and my models still have the problem when I am signed in, but I sign out and the problem goes away. (I am using Microsoft edge on a windows 11)

Hi @TheGuz. Thanks for following up. The issue is still present. When logged in it gives the failed rendering message. When not logged in it does not. From your testing it also appears that if you are logged in bit it’s not your own model the issue is not present. That should narrow down the issue a bit.

1 Like

Hey Thomas! I’m getting a bit closer to an answer. This particular model:

Was showing a renderbot issue because the USD file seemed to have a problem. That means everything looks fine BUT may not be viewable in AR on Apple devices. Sometimes the conversion of a complex model from .skp to .usd or .glb can be troublesome. We’ll be working to improve that as well as improving the messaging so they are more informative and not just showing a general failure.

Hey @TheGuz,

Thanks for the feedback. Glad the team was able to track down where the issues were occuring. Hopefully this will resolve a bunch of people’s issues. And as a user, Yes, informative error messages are a real boon. I’ll check back in a month or so. Hopefully it’s improved somewhat by then.

Happy holiday season!

HI Guys, I seem to have the same issue of failing to render… I have uploaded a swag of models and some work and some don’t… have posted this reply to permit watching the issue in anticipation of a solution.

We are working on more informative / less alarming messages for the future. Us simply saying “Failed to Render” isn’t as helpful as saying “GLB file failed to render”. I believe in most cases the .SKP file and thumbnail that we’ve always had, works great. Later we began rendering .GLB and .USD files for AR viewing and that conversion process can be finicky sometimes, which results in a “failed to render” message. Let me know if you find something else.

Lastly, the reason you don’t see the “failed to render” message when you’re logged out is because we only want to alert the owner of the model, no the entire world. Everyone else will probably just see that the View in AR button is missing.


1 Like

Hi @TheGuz,

Thanks for the update. Much appreciated.

& happy new year!

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.