3D Warehouse - failed to render

I feel you, it has become annoying and frustrating for me. I’m was trying to upload this one particular model just now, today even though I’ve purged it and it still shows the same “FAILED TO RENDER” nonsense. What has gone to the 3D Warehouse these days? Sometimes it works, somestimes it doesn’t.

1 Like

If you get “failed to render” try refreshing the webpage only in your browser.

What I find interesting is we keep getting told when we can’t access 3DW that SU17 is no longer supported but then the app warehouse works fine so why one and not both? The suits just think the peons won’t figure it out. I solved a bug in uploading and told The Guz and was told they were able to duplicate problem and they’d get right on it. The bug is still there years later so don’t hold your breath getting FTR resolved anytime soon.

I use SU17 and can’t download anything (Collada isn’t acceptable as a download option) so turnabout is fair play I upload as little as possible. Why should anyone go to the time and effort of making a model just to find out we get nothing in return?

BTW the current SU version and 2 years older rule would mean that 2019 ver should no longer be supported. When is that going to happen? The year will soon be over and I predict SU19 will be around into the following year.

I upload to the Warehouse just because I want to show off my work. Whether I do or don’t has nothing to do with an occasional hiccup. And…Trimble has removed many features that a lot of us liked. A lot worse would have to happen for me to “threaten” to reduce or stop uploading.

Sad to say, but it’s a fact, you aren’t causing Trimble any heartburn at all by not uploading to the Warehouse. If it hurts anyone, it’s the thieves who take models and sell on sites that cater to 3D virtual worlds (or whatever else they do with these models), and those who use the work of others to save themselves time and money. If they don’t snag one of your models (or yours aren’t there to snag to begin with), there are hundreds of thousands of others to choose from - not everything in the 3DWH is trash, or the thieves wouldn’t bother with the place.

Just sayin’…

I agree with you, SketchrUppr. I also experienced the same thing, always failed to render the model after uploading, many reasons this and that, big file, texture had to be resized, lines were hidden, blah blah… because before november 2021, I was always successful in uploading the model … the problem is only on the 3d warehouse website, I’m pretty sure that. and their team did not fix it until now (July 2022),

1 Like

SketchrUppr, I don’t mind uploading to share with others the problem is I’m not allowed to down
load and share what others have done. Collada is the only option and it’s crappy. The Collada file has to practically be redrawn to be able to use. I’m well aware Tribble won’t lose any sleep over it agreed they don’t care. As far as thieves go I quit uploading models as often as possible that may have potential to make profit for others without some trouble for them to use straight off the shelf.

Do you think it’s enjoyable to go to a lot of time and effort making a decent model (I do enjoy the process of creating) and not get anything but lots more effort to be able to use someone else’s model?

I’m just wrapping up a huge model and considering uploading MP4’s to the Forum and share what I’m doing that way. Just as I can only view so shall others.

Just statin’…

Can you verify that this continues to be an issue. I just looked at your account and it seems everything has a thumbnail rendered. Sometimes the servers can get a little overwhelmed with uploads and take a while… which is also room for improvement.

Hello, check the material used in your model.
Certain photographic or personalized texture (via an image in your computer) can be the cause of this error.

I seem to be having the same problem. I keep reuploading, But it just keeps failing to render.

Sorry for such a very late reply, sometimes it tends to work properly, and sometimes it doesn’t because of the server.

So I’ll verify that this doesn’t continue to be an issue as often as before. It’s doing more or less fine now. Thanks again for your help.

1 Like

Thank you for the update. Please keep me posted. I’m going keep an eye on this issue to make sure our rendering servers are not acting up.

1 Like

Hello admin, I have this file uploaded to 3dwarehouse with error Failed to render, can you fix it for me?

This is a user forum, maybe the following link can help you…

1 Like
1 Like

Just tried to render a model after quite a while not doing so. The model is pretty big (48 MB) containing many items from 3 D Warehouse. I suspect the complexity of the model is the issue. Just uploaded a 590k test model that rendered fine.

What can I do to have this solved? Is there a way to see some error log of what failed? That would also help Sketcup to solve the issue

That file size is on the limit permitted to upload a model, maybe that’s why you’re having trouble to do it, try getting rid of assets you downloaded that may being increasing the size of the file and get some low poly ones, something like a plant a couch a bed or a lamp can be heavier than the rest of the model. Can you share the file so we can check what’s the problem with it?


The file size also exceeds the limits of the Forum :slight_smile:
Find the file here: longstay coworking.skp

well, material resizer (extension) saw some big textures, after a small reduction (5 were brought down to 1024px), a quick purge and tag check, your model is now 37 mb

it should upload just fine now. I hope.


thanks for the pointer to material resizer. I brought the model down to 35 MB and it still fails.

is there no specs as of what is allowed or not?

well, just above your message is one from @TheGuz , Mr warehouse (the warehouse guy?) and he explains that the “render” issue is not directly linked to your skp file.

it’s not directly linked to your sketchup file, somewhere when converting to a GLB and a USD file (for preview and AR, there is an issue.

A little off topic although maybe not. Your model would likely render more easily if it was more efficiently modeled. Component instead of a group for the roof tile or better yet, a texture instead of geometry. You used a texture for the rool on the veranda to good effect.

Also simplifying some of the objects in the model would go a long way to helping the situation. Over 13k entities for the elbow is excessive as is the 55K+ entities in the rain barrel.

Inside you could do a number of things to make rendering simpler. There’s no views of the model that show King Kong on the computer screen. You could eliminate that image. Might also fix the desk lamp while you’re in there. The books and keyboard on the desk could be simplified.

There are a number of faces that should have their orientation corrected, too.

I also see incorrect tag usage.
Screenshot - 4_13_2023 , 7_12_33 AM

Cleaning up and streamlining your model would make it easier to render faster. I looked for the model in the 3D Warehouse and it does appear to have finally rendered.