3D Warehouse Download Problems

I’m having trouble downloading some of the models in 3D Warehouse. I can select the file by clicking the icon; but when given the download button, clicking it has no detectable effect. With most downloads I’ve done, after the steps stated above I’m served a panel asking if I want to download it directly into my drawing. This is not happening with the models I have trouble with.

Is there a special handshake or secret word ?

The 3D Warehouse no longer supports SketchUp 2018 or earlier. This went into effect about 3 months or more ago.You can go to the 3D Warehouse in your internet browser and get components in the Collada file type. Unzip the Collada file and import the .dae.

1 Like

Thank you, Dave; but I don’t understand. What URL do I use to access the 3D warehouse from my browser? What credentials do I use to log in?

This is the URL: 3D Warehouse A Google search for 3D Warehouse will turn it up, too. Use the same sign in as you used when the Warehouse supported SU2017.

1 Like

Since I last posted on the topic, I find that when I get to the 3D Warehouse with my browser (Firefox) and sign in, I can’t locate anything using the search panel. What is most strange is that typing in a search argument causes suggested terms; however when choosing one, I get an EMPTY message. It doesn’t seem to matter which suggested term I choose.


What category are you looking at?

1 Like

It seems not to matter. I’m trying to find a model of a woodworking vise. I have one that I uploaded but I’m looking for a different one now.

I’ve looked in All Categories, Building Products, Industrial, Interior Products, Utilitarian Objects and Other, all with the same results.

A while ago the default set of results was changed to Products. If you choose Models instead you will get more results.

1 Like

I must be doing something wrong every time and not realizing what it is.

I use my browser to go to 3D Warehouse. I log in and pass the CAPCHA test. I then choose Models (as Colin suggested) and get a group of thumbnails. I then type in my search argument and get these options: *(can’t seem to put the file here when I drag and drop it)

After the uploading indicator reaches 100%, I get an error message saying “Sorry, there was an error uploading that file. Please try again.” The ss I try to upload shows the options suggested when I type in the search argument, “woodworking vise”. Choosing any option results in a second screen which will not upload. This screen shows a message saying Empty along with other information,

The files are screenshots with .PNG extensions. I tried changing them to .jpg and got the same result.

You would want to open the PNG in Paint, then Save as to JPEG. That will reduce the file size.

For the original problem, if you click on the link that I gave, do you see the list of results?

1 Like

Uploading would mean that you are trying to put something into the Warehouse instead of downloading files from there to your computer. What are you actually attempting to do?

1 Like

Anssi, I’m trying to post screenshots to explain my problems with the 3D Warehouse.

Colin, I used FastStone Image Viewer to reduce the size of the files and save them as .jpg. I get the same result: the error message. When I click on your link I get the 3d models displayed but I can’t download them from the warehouse because I’m running 2017 Make. DaveR gave me a link to use in my browser in a message above. It is that link that I’m having trouble with.

I’ve probably lost what it is you are trying to do. I don’t understand why you are using Fast stone and what jpg files you are resizing or why you are talking about uploading when you were wanting to download a vise component from the 3D Warehouse.

What vise are you looking for?

There may be a connection between you not being able to attach an image to your reply, and that our links are not working for you.

Have you tried other browsers?

I have not tried a different browser. I’m using Firefox fully updated on Win 10 that I think is fully updated.

Colin, I went back and tried your link again. I found the file I wanted and found that I had to scroll my screen to see the collada file download option. I downloaded the file and will unzip it and move the result to my SU directory.

I will also circle back and try Brave to upload my screenshots.

Thanks, everyone, for your help!

Is it possible that you are using Run as Admin with Firefox? Or set it to Run as Admin somehow?
If so this could be causing your upload image issues.
@TIG would be able to offer more info on this but I believe Running a program, rather than installing it, as Admin can cause issues with info exchange between programs.

Running an installer’s exe file ‘as administrator’ ensures that the permissions for various file and subfolders that are involved are set up correctly.
However, running an installed exe file as admin will cause subtle problems… for example - if SketchUp is running at a elevated security level [as admin] then it cannot be affected by other apps running at a lower level of security - Windows Explorer always runs at the basic level, and therefore operations where if interacts with SketchUp would then be stopped, so there is no drag-n-drop of images into a SketchUp window etc…
It’s best to install any app properly, rather than trying to patch-up the mess…

And could that mean that Firefox running at an elevated level could balk at loading images from Windows Explorer?

While it’s running-as-admin Firefox would no longer be able to accept files directly from Windows Explorer - e.g. by drag-n-drop.
The best way is to try it and see what happens…