3D Warehouse and Add Geo-Location Blank Dialog Boxes

Windows 10, IE 11, Sketchup Pro 2016. No problems with SU 2015 Pro or 2016 Pro until upgraded to Windows 10.
I can go to https://3dwarehouse.sketchup.com/?hl=en and all is well. Google Earth Pro is working flawlessly. I have reset security level in IE11 to lower. I have activated Javascripts in IE11. I have re-installed SU 2016 Pro three (3) times. I have tried all I know to do and have followed as many users threads as I could find about this issue…
"Help me Obi Wan Kanobi you’re my only hope."
Many thanks to your staff.
Morris

  1. Please confirm you have followed ALL the steps listed in http://help.sketchup.com/en/article/3000056.

  2. Delete C:\Users\username\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp\cookiejar.xml and C:\Users\username\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp\session.dat, if present, and try again.

  3. Ensure cookies are enabled for *.sketchup.com and *.trimble.com and these domains are listed under exceptions in the antivirus.

  4. If the behavior persist, it could be that the javascript is getting disabled during the sessions. To test, open the 3DWarehouse dialog box, when you see the blank page please enter Ctrl+L, copy https://www.whatismybrowser.com/is-javascript-enabled in the resulting dialog box. If everything is ok you should see a page with “Yes”.

  5. Open 3DWarehouse dialog box (File>3DWarehouse>Get Models)
    Shift+click on the Search button
    Copy paste the debugging information in replies to this post

If you see an empty page or the search button in not available do the following

Enter Ctrl+L in the dialogbox
Copy https://3dwarehouse.sketchup.com/debugging.html in the resulting dialog box
Copy paste the debugging information in replies to this post

  1. In the debug page (above) try to login, using the login button in the top right corner, and report the behavior.

  2. Try to change the IE 11 settings to open as IE 9 ( Open developer mode in IE 11 by clicking F12. In the panel at the bottom of the screen, click the Emulation tab and set Document Mode to 9 and User Agent String to Internet Explorer 9). See

Debugging Information

User Info:
Name
Email

Server Info:
Branch
Build Date
Commit ID
Last Commit Date

Client Info:
3DW Version
User Agent
Mac OS X
SketchUp
Internet Explorer
WebGL Enabled
File API Enabled
IE8 Enabled
Mobile Enabled
Cookies Enabled
Cookies

Debugging Information from the Geo-Location Dialog Box…
Debugging Information

User Info:
Name
Email

Server Info:
Branch
Build Date
Commit ID
Last Commit Date

Client Info:
3DW Version
User Agent
Mac OS X
SketchUp
Internet Explorer
WebGL Enabled
File API Enabled
IE8 Enabled
Mobile Enabled
Cookies Enabled
Cookies

Appears your debugging info is blank, too. :slightly_smiling:

I’ve seen the white box because Microsoft complains about Google Maps security. See if you can do these steps:

First, open IE and go to the url https://3dwarehouse.sketchup.com/addlocation.html. Does the map show up?

Second, type an address into the search bar. Does the map zoom to the location you gave?

Third, click Select Region, does the window shift to try to do something, then fail? You should see a skp msg, and a resize rectangle coordinates in the url. If you get that, all is good in IE.

And that’s all the farther you can go in the browser - because the resize, imaging and terrain require SketchUp and our API agreement with Google.

Hi Barry…
Thanks! But no can do… after typing in and cutting an pasting in to check
the URL address resulted in the followIng:

The webpage cannot be found
HTTP 404
Most likely causes:

  • There might be a typing error in the address.
  • If you clicked on a link, it may be out of date.

What you can try:

Retype the address.

Go back to the previous page.Go back to the previous page.

Go to the main site and look for the information you want.

[image: More information] res://ieframe.dll/http_404.htm# More
information <ID
id=“moreInformation”>More information</ID>

This error (HTTP 404 Not Found) means that Internet Explorer was able to
connect to the website, but the page you wanted was not found. It’s
possible that the webpage is temporarily unavailable. Alternatively, the
website might have changed or removed the webpage.

For more information about HTTP errors, see Help.

Hey Barry… Thanks for your help.
Question: Why does my Extensions Warehouse work (see attached) but the 3D
Warehouse and Geo-Location do not?
Morris

Retry my steps above: I cut-n-pasted and the paste came in wrong. It’s addlocation.html, not addLocation.html and the there were trailing characters.

Debugging people’s network issues in forums is always fun, and it distracts me from poking my eyes with a sharp stick. Report back, and we’ll go from there.

Hi Barry…
Thanks, but still a webpage cannot be found error:
The webpage cannot be found
HTTP 404
Most likely causes:

  • There might be a typing error in the address.
  • If you clicked on a link, it may be out of date.

What you can try:

Retype the address.

Go back to the previous page.Go back to the previous page.

Go to the main site and look for the information you want.

[image: More information] res://ieframe.dll/http_404.htm# More information

@Barry, why is OS X in his User Agent string? [quote]
Client Info: 3DW Version User Agent Mac OS X SketchUp Internet Explorer WebGL Enabled
[/quote]

I don’t recall seeing that on a PC before…

john

@john_drivenupthewall, he copied the label side of the page, not the data side of the page, so that doesn’t help. Mac OS X label comes after User Agent.

@MorrisSmith, if you can’t get to https://3dwarehouse.sketchup.com/ in IE, you have network problems that you’re going to have to fix. No one else in the millions of SketchUp users has your network.

Now if Javascript was disabled, you’d still get an Extensions page, but 3dwarehouse would say: Javascript is not enabled. Please check your security settings for Internet Explorer.