3D Model freezing in SketchUp or shows major kaleidoscope-like distortion

Hi. Does anyone know what causes items in a 3D model to stretch across the screen into massive triangular shapes and also some to have a kaleidoscope-like finish? I have been having this issue off and on while modeling 1 file in particular. It had seemed to resolve itself but now when I try to go from an elevation scene back to the 3d model scene it usually won’t change at all. If it does change, it only loads partially or it looks like what I described above with a combination of the stretching and the kaleidoscope issue. Ultimately, I close the file and try again. It’s been at least 10 very time-consuming attempts at trying to get this scene to load.

Your profile says you are using SketchUp for Schools which is the web based version for school children. Which web browser are you using?

Check with the manufacturer of your graphics card and make sure you have the latest drivers installed.

Well that’s not correct. Thanks! I’ll change it. It’s Sketchup Pro. I did download the latest drivers recently to see if it would help but it hasn’t.

Did you restart the computer after installing the new drivers? Try repairing the SketchUp installation. It might help. Won’t hurt. Find the downloaded installer and right click on it. Choose Run as administrator and then choose Repair. Maybe time to update to SketchUP 2024. Maybe the new graphics engine will eliminate the issue.

I did restart.
Thank you. I’ll try the other options.

When I’ve seen things like this, it has always been bad graphics drivers. Don’t trust Microsoft, get drivers for your graphics card directly from the maker.

1 Like

I did go directly to the maker but it was crashing after the updates and prompting me to send reports. I thought maybe I didn’t install it properly so I tried again. No change so I turned off the crash monitoring to see if it would allow SU more time to load the file. Also, one day I think I deleted a few components from the Components Tray to see if that would stop the freezing. I thought that may be what caused the kaleidoscope stuff but I was not sure.

I tried repairing but it’s not giving me the option to run as administrator when I right click. I am accessing what I think to be the installer from the Program and Features section of Control Panel. Is that right? The only options are Uninstall and Change.

No. That’s not right. The installer would be in the Downloads folder. Or get it again from Why Use & Build With SketchUp | Why Buy SketchUp | SketchUp

You are right clicking on the application itself, not the installer.

Ok. Thanks.

Hi…sorry for the late update…I was able to find the installer in downloads and repair as an administrator. After that, I got a little further than I had been able to get and I haven’t seen the kaleidoscope issue but once I update a scene and try to save after, it just freezes. I’m going to try again now. If I want to try re-installing or repairing the latest driver updates (AMD Software: Adrenaline Edition) would I do the same steps from the downloads folder or should I just contact their software support?

Normally I would expect this kind of thing to be caused by graphics driver problems or a hardware fault. It could be a sign something is broken.

Thank you and thank you DaveR and slbaumgartner for your advice and assistance. I went ahead and uninstalled the AMD Adrenaline software and Chip Set according to their website then I checked Windows for updates again. There was an AMD update unrelated to what i had just uninstalled. I restarted one more time and everything seems to be back to normal. Better than normal, actually, because I use a day trading platform daily and had not been able to use it with SU simultaneously until now which makes me think the main issue was a bad SU install. Ultimately, I think the SU install repair along with the AMD software removal did the trick. I’m not sure if I will try to reinstall the AMD SW but if I do I will update this thread with the results.