3D Connexion Mouse


#21

After you select the button under Select Button, change the radio button under Select Task to Keystroke Assignment.


#22

I have a different Logitech mouse but a very similar interface. If I type m as you have and then enter, it appears to accept it but if I navigate away and back again, it clearly hasn’t. There doesn’t seem to be an Apply button or anything else to ensure the mapping has taken. Any ideas?


#23

Try not hitting enter, just click to another dialog after typing “m”?


#24

First attempt without hitting Enter. Second attempt includes hitting Enter. Result is the same.


#25

the ‘valid key combination’ is the preset ⌘0 shown in the Tool menu for Move…

possibly…

john


#26

Nice suggestion. Sadly still no dice. It won’t accept a double key combination at all.


#27

Do you have the latest version of the control panel for Logitech on Mac?

image


#28

Another great suggestion that has bitten the dust! Spent a happy half hour updating the driver to no avail.

Have now sent an email to product support.

I have a sneaking suspicion that it has something to do with recognizing my keyboard but it is a standard wired Apple keyboard so it shouldn’t really present any problems.


#29

I normally use a simpler Logitech mouse on my MacBook Pro but I installed the Logitech Option thing on my Mac for my M510 mouse. For whatever reason, I don’t seem to be able to get keystrokes to stick either. They do on the PC with no problem. I expect it has something to do with their Options software for Mac and not your wired keyboard.


#30

Useful to know Dave. Still, a bit unimpressive of Logitech if they can’t get it right for a major hardware platform.


#31

They aren’t the first to have problems for a major “hardware platform” as you can attest.


#32

True, true.


#33

Some how it is not displaying right, the letters should be Upcase, not Downcase


#34

As @jesse_s says, you can indeed enter a single keystroke that is application specific. You will have to use a shortcut key that is defined in SketchUp. I’d call that an inconvenience compared to SM, not a limitation.

I think this comes down to the fact that SM is using their own SU Extension to interpret the keys you’ve assigned to invoke the appropriate tool directly (without relying on a shortcut) while Logitech isn’t relying on any application specific knowledge of SketchUp - so all it can do is generate the keystroke you specify.

And one of the “predetermined” actions available in Logitech is a keystroke assignment - which keystroke is transmitted isn’t predetermined - it’s your choice.

Just for the heck of it, I just added a new program to my individually assigned Logitech button functions: SnagIt Editor. It opens automatically when I do I screen capture, and often all I want to do is copy the capture to the clipboard:


In fact, I USED that application specific key assignment to copy the above picture onto my clipboard before I pasted it into this post! So now, one of the buttons on my mouse does the following:
In SketchUp - same as hitting <ESC> on the keyboard
In Chrome, it’s my “Forward” button
In Powerpoint, it’s my “Back” button
In SnagitEditor, it’s my “copy everything to the clipboard” button


#35

You’re kind of late to the party, Steven. Simon has already tried to assign a keystroke to activate a shortcut. It works great on the PC. It doesn’t work correctly on the Mac. His GIF screen grab shows it. I’ve confirmed it doesn’t work on the Mac for me, either. Evidently the Logitech utility for this doesn’t work in the same way on the Mac as it does on the PC.


#36

You’re right, I missed that. Bummer that it doesn’t work on Mac!


#37

This is weird… I am on mac and have no problem assigning shortcut keys…

Could it be specific to the hardware?


#38

Two different Logitech devices and two different versions of their Options application. Could be, though, Aaron. I just installed their app this morning to try it for Simon.


#39

Whilst I wait for Logitech to respond, it would be useful to know from @TheOnlyAaron, say, exactly what he does when assigning a key. Let’s say he wanted to invoke Move and so needs to type an “m” into the keystroke assignment box. Would he use a lowercase m or an uppercase one (does it matter)? Once he has typed it, does he hit Enter? Does it make a difference if he uses the Enter/Return key on the main keyboard or in the numeric pad (if it exists)? For a very few things this does seem to make a difference, the numeric keypad one not being recognised as an Enter key.

The reason I suspect the keyboard is because part of the setting up requires you to state what kind of keyboard you have.


#40

Good news is that Logitech have responded already. Bad news is that they clearly don’t know what the problem could be. Here’s what they say:

Dear Simon,

My name is Arnel, I understand that you would like assistance with your MX Ergo Wireless Trackball.

Please follow the steps:

  1. Re-seat to another USB port. Bypass the use of KVM switch boxes, port replicators, docking stations, and USB hubs if any
    Prefer using USB 2.0 rather than USB 3.0 ports.
  2. Try another application so that we can check if it is only happening on a certain app or not.
    If that did not work,
  3. Try a different computer so that we can check if it is only happening on a different computer or not.
    4 Try to uninstall and re install sofware
  4. Try another computer.

For future reference your case reference number is 07417747. This will allow us to quickly find the contact history when you need additional help. If we do not receive a reply, your support request will eventually be closed and set to “solved”. A survey will be sent to you to gather your feedback.

To contact us by phone or obtain additional information (FAQ’s, Forum, Manuals, etc.) please visit support.logitech.com

Best regards,

Arnel
Logitech Customer Care
support.logitech.com