3D Connexion Mouse


#1

I was having major issues with my 3D Connexion mouse back in May this year, and slbaumgartner helped me to work through this at the time, although the final solution was to disable the mouse. I asked if there was a good alternative 3D mouse that anyone could recommend for use with Sketchup on a Mac, but no one had a suggestion.

After using a 3D mouse with Sketchup for many years (which used to work perfectly until May this year) I am staggered that people use this software without one, and I am hoping that someone has a suggestion for me?

Thank you for your help, Regards Andrew


#2

Can you give the model of the mouse that you were using?


#3

It is called a Space Navigator, the wired version.


#4

Did anything happen in May that could have affected the mouse, like an OS update say? I ask because I had huge difficulties getting my SM to work at first. The solution proved fairly simple in the end but I had to jump through hoop after hoop to find it. 3DC themselves were next to useless in sorting it out.

If it was working and then inexplicably stopped working without rhyme or reason, the solution may be harder to find.


#5

There was a combination of things. Sketchup released a new version, and 3D Connexion released some new drivers to go with it, but they caused issues.

3D Conn then released some updated drivers, which appeared to fix the problem, but in fact they were causing the whole computer to slow down in the background.

slbaumgartner introduced me to the Activity Monitor, where I could see that whenever the 3D mouse drivers were engaged, they started using memory uncontrollably, and within a few minutes of initiation, the whole computer would lock up.

I jumped through hoops of fire (along with a bunch of others with a similar problem) trying to remove the drivers and re-load them (learning along the way that the location of the drivers was in an Application Library on the HD, not under the user name as everyone thought at first).

About 20 attempts and restarts later, and having tried every convolution under the sun, I eventually found that the only reliable solution was to disable the drivers and disconnect the 3D mouse.

Ever since, I have been trying to find a decent solution, with no success.

The best I ever got out of 3D Connexion was for them to tell me that there was a new driver available, but when they told me the version number of the new driver, I realised that I already had that one.


#6

Horses for courses …

• Using a 3D navigator removes your hand from the keyboard.
• Navigation via keyboard shortcuts is faster than navigating with any type of mouse.
• Clicking a button on a programmable mouse is faster than reaching for keys.


Facebook Live: Operating Systems, Hardware, and Peripherals (December 15, 2017)


#7

Ok, so I wasn’t sure if you were talking about their 3 button mouse or their Space Navigator Product line.

I’m not sure I ran up against that version of the 3DxWare software package that was giving you problems. I’m currently using the basic wired 3D Navigator that I’ve been using for the past 5 years, probably the same one you have, on macOS High Sierra. I’m using 3DxWare 10.5.1, although it’s telling me that there’s an update to 10.5.3.

I checked the activity monitor, and I don’t find any of the drivers causing any problems with my system. You might want to use the uninstaller and start with a fresh download of the 3DxWare software to see if it still causes problems. Let us know what the result is.


#8

I think this is exactly what I had to do. But the real problem was with the firewall. During installation it seems that the process connects outside your machine and to do that has to have the firewall open. So you open it before installation and close it straight after. That was the solution for me. I would have expected 3DC to have known that and to have told me from the get go (or hey, why not put it in the info sent out with the mouse? radical, I know).

I came very close to giving up myself which would have been an expensive mistake.


#9

Thank you all for your comments.

  1. Jesse, I am running macOS High Sierra as well, so I will try using the 10.5.1 driver for the mouse and see what happens.

  2. Simon, I will investigate the firewall deal.

  3. Geo, I am intrigued by your comments about using keyboard shortcuts to navigate. Can you give me an example of a keyboard shortcut that I might use (I assume the programmable mouse button would do something similar to a keyboard shortcut)?

  4. I looked at the link you posted, but I’m not sure that I understand what I should be paying attention to?

  5. The thing I most typically do is zoom in on a detail to click on a point with the Tape Measure Tool, then I zoom out with the mouse scroll wheel in my right hand, while orbiting with the 3D mouse in my left hand, to the back or underside of the model to check a dimension, with the tape tool still engaged. I am struggling to imagine any keyboard shortcut that can deliver that functionality (but I would be delighted to learn if there is one).

  6. Can you suggest a programmable mouse that works well with sketchup on a mac?

  7. Do you know of any good tutorials that might explain all this to save you the effort? I have been searching but with no success so far.


#10

Sorry Geo, I have just watched a bit further through that video you posted and saw the MX Master programable mouse.


#11

If you want to make sure the people you reference see what you have written you need to ping them. To do that you need to use their “handle”. Geo would be @Geo and Jesse would be @jesse_s. Now they will probably read this post and see yours.


#12

No, but I can flag up a mistake I made so you don’t have to.

I upgraded my rodent collection in the summer going from an ordinary 3 button mouse to a SpaceMouse and a roller ball mouse. The SM arrived first and once I had it running properly, I noticed that you can configure both its buttons and other functions to map to SU commands. In theory, you can do a lot of what you might previously have been doing with menus or shortcuts without your hand ever leaving the SM.

My Logitech roller ball also has configurable buttons and is theoretically also capable of being tailored to SU. Except that it isn’t really. What it means in practice is that there are certain general computer commands that the buttons can be configured to invoke and you can change them between programs. Personally, I feel that is a bit of a cheat as I can’t believe anyone would want to invoke the same commands in different ways just because they were using different software. I have configured the two side buttons to take the place of double clicking and triple clicking and that’s proved very useful both for SU and generally.


#13

got it, thanks for the tip


#14

@simoncbevans, understood on the programmable mouse thing, thanks


#15

@Geo I know this is going to make me look like an idiot, but sometimes that can’t be helped. I have been going through some tutorials on navigation and made a discovery. Because I have been using the 3D mouse, I did not know that you can press on the scroll wheel of an ordinary mouse and it switches to orbit. While it is certainly not as nice to use as the 3D mouse (with the 3D mouse I can zoom, pan, tilt and orbit all at the same time), I now understand how it is that people would be happy to use only the standard mouse.


#16

I’ve configured the two “extra” buttons on my Logitech M570 as follows:
In Sketchup: <esc> and <space>
In Chrome: Forward and Back


Clicking “Configure”:
image
and


#17

Yes Steven, and your screenshots demonstrate exactly what I was getting at. First you select your application, then you select the button, and then you select from a pre-determined list of tasks that will be the same whichever application you select.

To demonstrate the limitation, suppose you wanted a mouse button configured to invoke he Move command in SU. I can do that with my SM. I can’t do it with my Logitech. That’s a limitation.


#18

I think you might be able to specify in the section where you pick a keystroke to simulate the “m” key. That would invoke the move tool.


#19

Yes. In the Logitech control panel you can assign keystrokes to buttons so M would call the Move tool.


#20

Ima try this for sure. Maybe I missed a trick (often happens!).