2019 SketchUp Pro Plugin Error

I just installed the free trial version of sketchup pro and I wanted to try to intall the open studio plugin.
I changed the plugin file format from .rb to .rbz and tried to add it in the sketchup.
But they said it was unable to install and I dont know what’s wrong.
Can anyone help me out here?
Thanks so much!!

Simply changing the extension from .rb to .rbz doesn’t make a script installable. You would need to pack the .rb into a zip and rename the zip file. I expect there’s more than just a single .rb file required, though.

You should get the most current version from the source instead of trying to copy old extensions from a previous installation.

You should also check out this thread:

Thanks for your reply!
I downloaded the latest version of the extension and I tried zipping the whole file and then changing it to .rbz
I tried to install it but sketchup says it is “not signed” .
It cannot recognise the open studio plugin and the name is “changelog” instead.
What should I do?
Thanks again!!!

Why do you think you need to zip the downloaded file and rename it? Have you taken a few seconds to read the installation instructions?


It probably won’t show as signed. That generally isn’t a problem unless YOU set loading restrictions for extensions.

Cause i thought you meant i should zip all the plugins into a zip and rename the zip file to .rbz?
Yes i tried following every steps for the open studio installation guide and it is still not working.
I wanna cry…

I certainly didn’t mean or say that!

You should contact the Open Studio people or get on their forum. Did you read the other thread I linked to? Open Studio is going away this year.

Sorry i misunderstood that!
i see, cause i am trying to install different energy models for simulation in sketchup.
i will try to contact them.

I’m a M&S Sketchup Pro who just updated to 2019. The Sandbox extension does not work on macOS. I uninstalled the one that was in the Extension Manager, quit, re-opened, went to Extension Warehouse for it, saw that it says “compatible with Sketchup 2019,” downloaded, installed, quit, re-opened. Now I selected Tools, Sandbox, From Scratch. I get the ability to draw out the first direction, but clicking does nothing. If I stop moving the mouse and type in a value, it freezes the line. I move in the second orthogonal direction and no trailing ants line follows. I click…nothing. I type a value…nothing. I must hit Escape to get out of the tool. It is broken (tested several times with and without quits and re-opens).

While you are in the trial period, you can give Sefaira a chance!

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.