Ruby scripts in Pro 2016?


#1

Hi. I recently downloaded the pro version of 2016. However when I tried to install my ruby scripts, it did not RH recognize any that had a .rb extension, only .rbz. I tried just changing the extension from rb to rbz but it didn’t work. Help?


#2

changing the filenames .rb to .rbz will never work…

you would need to first create a .zip file from the .rb and then change .zip to .rbz…


#3

The .rb extension has graduated long ago.

you can still put them in the correct extension folder to install them, but not recommended.

Installing Ruby Plugins (Extensions)
http://help.sketchup.com/en/article/38583


#4

Joseph your post contains mis-imformation…

.rb files are still perfectly valid in SU v16, and I described the ‘convenience’ method for installing them…

if they have a required ‘folder’, then that would also need to be included in the .zip [before the name change]

they may not work, if the code uses obsolete functions, but that is a different issue…

they are not ‘extensions’ but can still utilise the ‘Instal Extension’ if wrapped as a .rbz…

an ‘Extension’ is a special plugin that satisfies a number of set criteria,
the first is they must contain a .rb file, so I hardly see that as being redundant…

The BEST advice for the majority of uses is to look for an updated version of any older plugins first…

john


#5

My mistake John.

.rb works just fine as you have said.

What I meant is that drag and drop of .rb file method is not necessarily advised.
Ever since .rbz was introduced, SketchUp is obviously trying to stay away from inexperienced users messing with their “Roaming” folder.

@sarcoguy,

You CAN put the .rb file into the “Roaming” (Windows) or “Application Support” (MAC) folder and get it to work instead of using the “install extension” method.

or try zipping and change it to .rbz.
Though as John said, try to look for updated version.


#6

Thanks a lot for the tips. I am coming back to SketchUp after not using it for a long time, hence the older scripts.

One other problem - the SketchUp how to page doesn’t have any info for '16. And I am using Windows 10. If I go to windows explorer I can go to C/USERNAME but there is no folder called AppData, and a search for a SketchUp folder within my username doesn’t come up with anything. I know, I am probably missing something very obvious but any further tips would be appreciated. These old .rb scripts will save me a lot of time if I can get them to work…


#7

The AppData folder is invisible in Windows by default. You will have to select the “show hidden files, folders and drives” option in the Windows Explorer Folder and Search options to see it. Or type %appdata% into the Windows start menu search box and press Enter.

Anssi


#8

SketchUp has recently been updated to Ruby version 2.0, and a lot of older scripts do not work because they use Ruby 1.8 syntax, or use old arguments to Ruby core methods that have been changed.

So first look for updated scripts, plugins and extensions from the original author at:

or