2018 Stops working after a couple of days


I’m in the process of of switching from a Mac system to Windows. I also recently upgraded to 2018. The problem I’m having is that Sketchup will work and run for about 4 days and then just won’t open, producing a bugsplat. No changes to settings are being made, nothing.

Last night I put my machine to sleep, and when I opened it up this morning Sketchup had stopped working and neither it nor layout will open. The problem is fixed if I uninstall and then reinstall the programs but i don’t want to do that every couple of days.

Any help would be much appreciated, this is making my transition to windows very very frustrating.


Have you tried turning your computer off and restarting it? I have bad experiences about PC power management and OpenGL display driver support. I never let my computers sleep or even less hibernate. Usually something starts misbehaving if that happens.
A Mac vendor once told a friend that Macs never need to be turned off. Not quite true, but probably more so than with a PC.

Hmmm that I have not tried. Old Mac habits die hard! This windows machine, it’s like driving a manual instead of an automatic hahaha

I just did a fresh uninstall reinstall because I needed to get to work but I will try actually turning the machine off from here on out and see if that works.

Thanks for the tip, I’ll report back if it works

So after the reinstall the program worked all day. Then just now after walking away from my desk for five minutes I closed the project i was working on, went to open a new one and now I’m getting the same bug splat and sketchup is not opening.

Any more tips?

Go to the install .exe Right Click on it and choose Run as Administrator then when offered select Repair. Once that is all done restart your PC and see how it goes.

And check power saving on your PC, it may be set to sleep or reduce power after 10 minutes which could be affecting it.

That’s quite true, I have learned to turn off my mac at the end of the day and thus avoid unexpected behavior.

Hmm another uninstall reinstall session and now layout won’t open but sketchup will.

I can get layout to open and run if I run it as an administrator, but i’m never given the option to repair.

One thought I had. I bought this machine refurbished and it came i think with windows 8 and was supposed to have a free upgrade to windows 10 pro. However I was never able to upgrade it to pro. Something was messed up with the license and to make a long and story short, I;'m running a 64 bit version of windows 10 home. WOuld that be affecting things? Should i buy and upgrade to windows 10 pro and just totally start with a fresh install of everything on the machine?

Thanks to everyone for your help. I’ve come to these forums a lot over the past years and this is the first time I’ve ever had a problem that couldn’t be fixed with a quick search through all the knowledge you have all contributed here…

I said the Installer .exe
Go and find the original Installer file, probably in your downloads folder, select it, right click on it and Choose Run as Administrator, then you’ll get the option to Repair.

Just tried that and still not working. Layout isn’t producing a bugsplat now, just a windows error.

Sketchup is working fine at the moment but i’m having to run Layout as an admin.

crashes during the application launch are typically related to a flaky OpenGL support of the used graphics card driver or a failed installation of the SU prerequisities, i.e. the required MS runtime libraries.

The latter can be excluded because SU/LO did already has worked… with Quadro drivers especially of old Quadro models known as being problematic this could be a direction to investigate further… e.g. by checking for the latest driver version with your notebook maker and/or nVidia (installed version: “Win+R > dxdiag.exe > Display…”).

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.