2018 Pro keeps telling me I am not online.!

I just installed 2018 on my computer (as an administrator), but cannot register the software because 2018 says I am offline. My computer is hardwired to our network. I have re-installed it several times, and the same thing happens. I even contacted IT about a possible firewall conflict, but no resolution.

Any suggestions?

SU uses the domain “google.com” (sigh) for checking the availablity of an internet connection and therefore fails if “google.com” is blocked by your firewall or proxy.

If valid open with a text editor as e.g. Windows Notepad (not word processor) the file “C:\Program Files\SketchUp\SketchUp 2018\resources<locale>\i18n.dat”. Go to section “[ONLINE CHECK]” and change value of line “ONLINE_TEST_URL=” from the default URI “Google” to e.g. your own domain or “http://help.sketchup.com”.


I looked at the other threads. The one you offered comes closest to my problem, but the recommended fix was to: Use a text editor to open the file “C:\Program Files\SketchUp\SketchUp 2018\resources\i18n.dat. I went to C\Program Files\Sketchup2018\resources - and the only file folder in that portion of the directory is en-US. There is an i18n file there, but it is a video file. It took me a while to understand that the video file type listed was actually a .dat file. Then it took a while to figure out how to edit it using notepad. I was making the change recommended, but couldn’t save it because notepad reserved editing that file to administrators. I am the administrator for my sole machine, but wasn’t right clicking on notepad to expressly open it as an administrator. The learning curve here is steep. Anyway, I changed the “Online_test_URL” reference from google,com to http://www.help.sketchup.com/en to no avail. I even restarted the computer to see if that would help - no joy. The same stinking “you are offline” message still pops up. I use BitDefender Internet Security, but my firewall settings give Sketchup full internet access on any connection, so that isn’t the source of my problem. Any additional pointers would be appreciated. Bear with me, I’m enthusiastic, but not all that knowledgeable.

Try https instead of http, it’s ‘safer’

done, and finally I’m connected. Whew. Bumpy road, but I’m at my destination. Thanks!