2018 Pro - Deauthorized computer, but still can't authorize new computer

I have my main Windows computer and just upgraded my mac laptop. I deauthorized my old mac laptop but still can’t put the serial and auth code into my new code (get an error message that I still have too many computers authorized). Is there anywhere I can review which computers are authorized?

You need to contact support, but there is a catch 22, I guess, because in order to get help or support, you need to have an active maintenance plan ( which isn’t possible anymore) or an active subscription plan ( and than you wouldn’t need to know on which machines it was activated because you would have been using the ‘latest and greatest’
When did you bought it? You might have access to a newer version (2019).

Thanks for the response. I can’t remember when I purchased it. Even if I have access to a newer version (2019), I still can’t get support help on the deactivation, right?

I will download 2019 and see if my credentials work, but I imagine the system still thinks I have used up my two computers…

Tried to use my serial number in the 2019 version and it said it wasn’t a valid number.

Does Sketchup support monitor these forums? Any way I can do a quick check with them without an (impossible to get) support plan?

This is an user forum. Some SketchUp employees visit quite regularly, but this is not part of official support. @colin has often been able to sort things out for many people.

To remove an activation of a classic license you would remove the license from the old computer. When you do that it shows up as a deactivation in our system, and would free up that activation to be used on a new machine.

I only see 2018 for you, so your serial number that starts with TA will only work in 2018.

Do you still have the old Mac, and can open SketchUp to then remove the license?

BTW, I don’t see any deactivations for your license, so I am wondering if you deauthorized a trial subscription instead of removing the license.

Ok - I just figured it out. Explanation for anyone curious or trying to sort something like this out in the future…

Basically, it was the same license error that was happening where the “online” check was broken:

However, when you DE-activate, you don’t get an error message, so I changed that online check to point to bing at https and then added the license back to the old mac. THEN I was able to deactivate it successfully and have it communicate that to the servers. I then added my newer macbook.

1 Like

Good findings. I will point that out to support, that removing a license when you are having network connection issues will silently leave you thinking that you had removed that activation.

1 Like

We always recommend to test if it is really gone. So after the deauthorization, quit SketchUp and then start it again.
If the deactivation failed, the license woud still be there, if you are prompted to add a license, it worked!

In this case, I did do this (prior to the fix described above). When I quit and opened the app up again, it still appeared as though the license was gone.

I assume this is because it was not connecting as mentioned above and couldn’t pull that it still had an active account.

1 Like

Perfect - Worked for me ! Thanks !