Zooming in and out in Layout

Just downloaded the 2023 version of sketchup and layout. I am having a problem with the zoom feature in layout. I use the wheel on my mouse to zoom in and out, in the 2021 version I could simply hover over where I wanted to zoom in, and it would zoom in on that spot. However, this new version just wants to zoom in directly in the middle of the page and I have to use my pan tool In conjunction with the zoom. This makes it much more difficult to orient my object on the page. Is there a setting that will change this or is this just how it is now?

It’s not “just how it is now.” It should work like it always has.

I wonder, did you actually install SketchUp and LayOut 2023? Or are you just running it from the .dmg? What Mac OS version? What mouse?

I just downloaded it to my computer yesterday. Downloaded it from sketch up website, opened the download, clicked and dragged it into my applications folder like I have in the past to install it (I believe this is the correct way to download it). My version is 13.4.1

That is the correct way to install it.

Please add that to your forum profile.

Try rebooting your computer. Does it still act the same?

I just restarted my computer. I tried opening a new layout with a different sketch up model and it is still behaving the same way. My mouse is just a standard mouse nothing special about it.

Maybe @colin would have some feedback but what you are seeing is not normal behavior for LO23.

Are you able to do a screen recording of what is happening ?

The recording is too big to paste in this box

Ah… That different from what I was expecting. I thought you were talking about zooming in on the page. You didn’t say you were opening the viewport and zooming in the model. That said, zooming does zoom toward the cursor position in Lo2023 for me.


My suggestion would be to don’t do that, though. You can wind up creating all sorts of headaches for yourself later. Better to create scenes in your SketchUp model that show it as you need and leave the Camera properties unmodified in LayOut.

1 Like

I have always created scenes in layout and it has never been a problem before. :frowning: I am definitely a basic user of sketch up and have a lot to learn. I will have to look into creating scenes in sketch up. However, I still don’t think layout is supposed to act this way, as it has never done this in the past with earlier versions

I’d say you’ve been lucky. If you ever have any need to go back to the SketchUp model to make updates and then have to reset the viewport to get it to update, you’ll see the problems. Especially if you have added labels and dimensions in LayOut.

I agree with you about that. What if you start zooming with the cursor on the model instead of in empty space?

Yes I have done that before. (Made changes in sketch up and then went back to my layout and it will give me the option to update or not) sometimes I do it on purpose if I need to change something. it doesn’t matter if my cursor is over the model or not it just wants to zoom to the middle of the page and not what my cursor is hovering over. Is there a setting that can be changed or maybe it just didn’t download properly and I need to try to download it over again?

There isn’t a setting for that. Maybe reinstalling it would help. Wouldn’t hurt.

Here’s a quick example of one of the issues that can occur when you’ve modified the Camera position in a LayOut viewport and then have to reset the viewport.

The viewport at the top was made using the same scene as the other viewport but I double clicked into it and adjust the camera to show the leg for dimensioning.

After resetting the viewport it shows the perspective view again The labels and dimensions are still attached to the part of the model they were attached to before but now the leaders point off the top of the page and the dimensions are so far away they can’t be seen at all.

This kind of thing becomes even more chaotic when you use the Last saved SketchUp view as the “scene” because if you go back to the model and make any edits you can be sure the camera position won’t be the same when you save it. Then even viewports that haven’t had their camera position modified will change.

Hmm… This is definitely more advanced than anything I have done! I tried re-downloading sketch up pro from the sketch up website. and its still doing the same thing :frowning:

There’s really nothing advanced about what I showed there.

FWIW, there are 782 LayOut files in the folder for one of my clients. Half of those are the backup files so 391 LayOut files for just that one client. Not one of them ever required zooming or panning within a viewport.

Maybe @colin can try zooming in a viewport on his Mac to see if he gets the same result.

it sounds like I need to learn how to use layout properly. I have just created scenes and added dimensions and notes and labels all in layout since I started using the program.

1 Like

To help achieve your goals, some time spent at the SketchUp Campus and at the SketchUp - YouTube channel will be very worthwhile. Both sites are from the SketchUp team. On the YouTube channel, pay attention to the Square One Series. It covers the basics for each tool.


It looks like the zooming changed between 2020 and 2021. I’m waiting for Trent to reappear after lunch, to ask him if there was an intended change.