Zoom clipping & location

Hi, I’m a hobbyist and created a model of a home. I’m having trouble getting rid of the zoom clipping, where objects in the foreground are not shown.

In particular, I like to add a few scenes looking out of a window, and when I get within 1-2 meter of the window, the window already disappears.

Now, this already seems like a difficult scene, as I want a relative high field of view (seeing the surrounding area when looking out of the window), ideally 60 degrees, but 40 degrees is acceptable.

Strangely, I got a good scene the other day, and despite that I have a screenshot with the scene that I liked, I can’t reproduce it anymore. It seems that the camera clipping is already happening at 2 meter distance instead of 1 meter distance.

What was changed is that I moved my model, as I found that my previous geo-location was somehow off by a few hundred meters. Also, I added more of the surrounding area, increasing the size (length x width) of my model.

Is there a way to change or disable the zoom clipping?

If not, could someone explain why a change of a location influence the camera clipping plane? On https://help.sketchup.com/en/article/36261, one of the suggestions is to move the model closer to the origin. What I did is move the origin of the top-level in the hierarchy, but this did not work.

Are there any other suggestions how to deal with the camera clipping plane? Is there a explanation when exactly this clipping happens, and at what distance? I assumed that it would only depend on the FOV, but given the suggestions at the above help-article, it seems that other factors, like the size of the model also are in play.

Thanks for investigating so much on your own! It’s likely that you have the camera set to Parallel Projection. Try using Perspective instead, then there should be no clipping.

Thanks Colin.

I used the Perspective Projection already (using a Parallel Project when inside a building is hard in my experience).

It seems that I got the previous result by setting the axis origin after all. Somehow the effect wasn’t instantaneous, and I had to switch scenes a few times to got it to work.

I just wish this clipping plane would be explained in more detail. I still don’t understand WHY a change of origin has any effect on the clipping plane. Also, I don’t understand the HOW: when I select another group or component in my hierarchy, the axis change (to the origin of the group or component). However, I never saw the clipping plane change just by activating another group.

That makes it less simple. Would you be able to show us the model? You can drag the SKP into your reply.

Camera Clipping Plane is a necessary display optimization where the computer only draws things that might be visible to the viewer, thereby reducing the rendering load and greatly speeding up the application.

Modeling technique can help manage camera clipping.
Given it’s an integral part of OpenGL rending, there’s no way to shut it off.



The R,G,B Drawing Axes are adjustable. They can be placed and oriented any way you wish.
By default, the adjustable Drawing Axes are coincident with the inalterable World Axes of SketchUp’s 3-axis Cartesian coordinate system.

Repositioning the Drawing Axes doesn’t change the distance between the model and the World Axes Origin

To return the Drawing Axes to their default position, aligned with the World Axes:
• Right context click in empty space near one of the Drawing Axes > Reset

See this section of the SketchUp Sage site:

Clipping Plane — SketchUp Sage

2 Likes

In my opinion the best way to avoid this situation is:

  1. use right units (meters for large models for example cities, centimeters for architecture etc.)
  2. start modeling near 0,0,0
  3. setup shortcut for “Zoom selection” and use this

There is interesting article about display problems due to distance from 0,0,0

Geo & roju, thanks a lot for the interesting pointers, and correcting my incorrect assumption (that drawing axis and world axis are the same thing).

I did some testing, and found a relative good predication:
The near clipping plane distance = the far clipping distance divided by about 700 plus about 5cm to 10cm.

This prediction was accurate to a factor 2 for a model of sizes 10, 300 or 2000 meters. I only tested the Perspective view with 35 degrees Field of View (not Parallel Projection).

The far clipping distance is basically the distance to the furthest point seen from the viewpoint (the camera).

Note:

  • Points behind the camera don’t count. It’s just the furthest point you can see. So if you are at the edge of the model and turn the camera, the clipping distance changes.
  • Hidden geometry still counts, unfortunately. If you have a large hidden plane. In my case, I had a 1.4km x 1.4km hidden Location Snapshot, so in the center, the far clipping distance was always at least 700 m away, and thus the near clipping distance at least 1 meter.
  • The far clipping distance is at least the distance to the absolute origin coordinate point. So it helps to move the model if the origin point is outside to models boundaries, but when it is in it the boundaries, moving the model does not help (even if it is far from the current camera viewpoint).

Edit: I found that the above prediction is too limited. While the visibility of groups does not influence the clipping plane, the current selection does. I am very surprised by that, as the model itself is the same.

While I failed to find the exact criteria, for me it helped to move large group of “surrounding” buildings to a top level group, or even split these into smaller sections and move each to the top level.

The field of view settings does not really seem to change the clipping distance.

The only thing that will remain hard is getting a camera position which shows distant parts of the model (thus large field of view and large far clipping plane) along with a part of the model close to the camera (which require short near clipping plane).

I suspect there are two work-arounds:

  1. move the camera a bit back, and setting a smaller field of view, although this will show less of the background. (if you want a view from inside a building, and this means the camera has to move behind a wall, perhaps hiding the wall with a section plane is an option.)
  2. Use a vertical panorama with a background image, instead of an actual model.

A pity, because my approach to make a rough model of the surrounding area as the background seems foiled here.

A third option is to make a feature request with Trimble to have a larger factor between far and near clipping planes, so the near clipping is less of an issue.

That’s not going to help on your current project, though. Probably not your next project, either.

How about a fourth option? False perspective. Scale down your rough background model and move it closer to the camera.

Regretfully, I found that my above prediction of the near clipping distance is too limited. While the visibility of groups does not influence the clipping plane, the current selection does.

The image clearly shows this behaviour: it is a screenshot from four views of the same location. The only thing that is different is which group is open for editing. The second sceenshot, where the group “surrounding area” is open for editing, has the best clipping (almost none).

Unfortunately, I can’t think what is causing this behaviour. If you like to play around, please do! All suggestions are welcome.

The model is: Clipping test 2.skp (2.4 MB)

(FYI, I hereby publish this dressed-down example model under a Creative Commons v4 attribution license, once finished, I’d be happy to publish the full model too).

I propose to remove “Openstreet map data”, finish building modeling and then copy “Openstreet map data” back.

Try to remove map and check your scene.

I was just testing and noticed the same thing, that the house is fine if you remove the Openstreet map data.

Somehow, if I move the “Openstreet map data” to the top level (root) of the outliner tree, the clipping plane improved a lot.

So my suggestion is to move large groups to the top level and optionally split them up into smaller segments and move those to the top level of the tree.

@roju, thanks for the suggestion. I’ve found free plugin that more or less automates this process: http://www.suplugins.com/edit.php.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.