When I orbit the drawing disappears

Hello Everybody !

I got a problem with viewing and doing anything with my Sketchup.
I use basic Sketchup 2017 on my Mac computer. Using Sketchup for years but I have to apologise for not using the correct Sketchup language.
I contacted Apple but they could not help me.
The problem starts out of nowhere and with about every second drawing. When I orbit to look around the drawing, it disappears. When I click standard views I can not see the drawing. I would need to use orbit very, very carefully to see the drawing but it will disappear again and again.
In order to continue the drawing I would need to save and close the drawing. Open it again, do not touch the drawing, copy the drawing and paste to a new drawing.

Please help !!

Thank you

Take a look at Geo post, it maybe has to do with it.

I believe you encountered an issue called ‘Camera Clipping Plane’. Make sure there no objects far from the origin.

Also you can use Camera > 'Parallel Projection’ to get rid off that effect. (Also use ‘zoom extent’ tool if necessary)

I had this problem while using parallel projection in the camera tab. Make sure you are using the perspectivze option.


Hello !

Thank you for the answer. It must a different reason. I always use the perspective view.


Is your model or part of it at a great distance from the origin? Hit Zoom Extents. What happens?

Hello !
Thank you for the answer. I use the perspective view. Do not like the parallel. I see it more like a issue with orbiting. Too much up or down or left or right, than the drawing disappears.
That issue does not occur on all drawings. The current one I am working on does not have it but it can happen any time or not happen at all.

When i click on zoom extends the drawing disappears.

Ha! That means that something, probably a stray bit of geometry, is located at a great distance from the rest of the model. If the model is near the origin, drag a right to left selection box around the area away from the model to select that geometry and then hit Delete.

Try Zoom Extents and see if your model shows.

1 Like

No. When I click on zoom extends the drawing disappears. Everything is close to axe crossing. I extended the zoom with the mouse wheel and tried to mark and delete everything if anything is there but I can not see it. Still the same issue

Maybe there are hidden elements, zoom exgtends should show everything you drew, if you don’t see nothing maybe you’re far away from the origin and that could be because the program tries to show you everything but there are still some elements far away from the origin.

I’m going to write it here what this site says:

SketchUp Sage Jean Lemire describes several ways to find a ‘lost’ model from a clipping problem.

  • Try turning perspective on if you are set to “Parallel projection”.
  • If you still have problem, it may be possible that your model is too far from the axes origin. If this is the case, try moving the model near the origin.
  • If it still do not solve the problem, it may be possible that you have a stray geometry very far from the model and that it may cause problems with OpenGL. Try this procedure to get rid of any stray geometry:
  1. Orbit, Zoom and Pan to make all of your model visible.
  2. Select all (CTRL-A). this will select all the model plus any geometries that may be residing anywhere. Make sure that you make all visible and turn every layers on to be able to really select all.
  3. Pres and hold the SHIFT key to Add/Subtract from the selection.
  4. While still pressing the SHIFT key, do a window select and select all of your model. This will deselect the model and keep selected anything else.
  5. Press the DELETE key. This will keep only the model that you selected.

Let us know if this fixes the issue.

Could you share the SketchUp file here?

Did you try dragging a right to left selection fence around the empty space away from the model? The Zoom wheel doesn’t need to come into this.

How can you do that ?

Attach a file?
When you’re editing your reply use the 7th icon from the left.
Or just drag and drop from your file explorer to the browser window in where you’re writing (at least on Chrome)

Nope. Still the same.

Yeah, then attach your sketchup file to let us see if someone see something wrong.

Is your model 2D with text annotations? There is a known bug (that so far lacks reproducible test case) that can cause text’s leaders to become infinite which causes issues such as you are seeing.

1 Like

Hi !
As a matter of fact , there is one 2D drawing with text !!
I have a 3D model and 2D one with text. I experienced issues with vanishing leaders before, depending on the viewing angle, but that was not to the point that I could not work on the drawing.

I have exactly the same problem with the model I am working on. All the objects are close to the origin, I have deleted any spurious distant objects following the earlier instructions and still everything disappears when I orbit 180 degrees of the object. I have reinstalled Sketchup and that doesnt help.
Finally I fixed it… I copied the whole architectural model I was working on and pasted it into a new file.