Wrong shadows?


#1

Hi. I’ve made a model of a house As Existing, The model is not Geolocated as it is not important that the shadows are accurate. I set shadows with a UTC of -1:00 just because i could get shadows that would look good.

Then I duplicated the file (save as) to make a second file showing the house As Proposed. I’ve altered the things that will change but suddenly the shadows are wrong - the UTC is the same, the time and date are the same, but the shadows are different. You can see that in the Proposed view the time only goes up to 5:21 so I can’t set it to 8:39.

Is there a way to reset the UTC?

,

thanks
Paul


#3

The original isn’t geolocated as you said.
What does the second file say now about its location. Is is perhaps in Boulder? It’s just a wild guess but who knows what possibly happened making it geolocated when copied.

added:UTC = -1:00 doesn’t seem to match (Boulder for instance) with whatever its location is now.


#4

The UTC setting isn’t the problem.
The problem is the two models are in different locations on Earth.

Every model has a Location, even when the model is not Geo-Located.

The default location in SketchUp is:
USA
Boulder (CO)
40.018309N
105.242139W

Your screenshots indicate UTC, Date and Local Time are set the same in both models.
Nonetheless, notice the drastic difference in the respective sunrise and sunset times.

Check the Geo-location of the models.
Given the 24 hrs of daylight indicated, my guess is the one labeled “existing” is near the North Pole.


Window > Model Info > Geo-location > Set Manual Location


Existing


Proposed


#5

Both models show the same answer -
Under GeoLocation > Add Location is available, but Clear Location and Show Terrain are both greyed out.
Under Model Info > it says ‘This model is not Geo located’
I’ve set Camera View to Top in both models and they both face the same way.
I’ve right clicked Reset on the Axis origin for both models.

Interestingly, in the Proposed model, I’ve been able to ‘mimic’ the shadows in the Existing model by setting the time and date considerably earlier (earlier in the day and earlier in the year, but still at UTC -1:00)

So no luck yet…


#6

I was hoping that I’d done something stupid, and there would be an easy fix. In the meantime I’ve done another save-as with the proposed model and I’ve now GeoLocated it to where the house really is (Northants, England). The shadows now work properly, though I now have quite a bit of work to do to reset all the shadows in each view for my drawings (in Layout) - as each elevation is set at a different time of day.
This seems to have been a straightforward SketchUp glitch… - has anyone else experienced this?


#7

Hi Paul,
I too had this issue!!
I copied a model as I wanted to create the same look using the same external but on turning shadows on I was faced with the same issue… everything matched accross both models yet the shadows cast were in different locations!.
I just did the same as you and changed it to look the same, I too think its a glitch but I am very new to this program (3 weeks in) so I questioned my current skill

Cheers


#8

Could you share the original model so I could try doing the same (copy to other SketchUp instance, etc) to try to find what is going on?