Wrapper material in Vray for Sketchup doesn't catch shadows

Hello everyone. I can’t solve this problem for like month, so I will be glad for any advice. I try to place objects on real photography, so in order to make objects reflection on the floor/walls, I need to apply matte wrapper material to floor/walls as a shadow catcher and make the walls invisible to reveal the photo. Basically as they show in the video: https://www.youtube.com/watch?v=nUVhgupu7fs&t=7s .
I follow the instructions, yet my wrapper material doesn’t catch any shadow. It does reflect materials, when i use a very glossy material as a base to the wrapper, yet still no shadows. Any ideas, where should be the issue?

Is the material’s texture from a PNG or a JPG ?
I known that PNG images in SketchUp don’t ‘receive shadows’, but JPG ones do ?
Is there a setting to affect this ? Vray is not my métier…

Material’s texture is from Vray’s library, so there yould be no reason for the wrapper to reflect material, but not to catch shadows :confused: But thank you for your reply :slight_smile:

Looks like a Vray material setting…

You need to switch to CPU render, not CUDA/RTX.

wra-02

Honestly, I don’t even have CUDA/RTX option, I have only CPU/GPU and I always render on CPU. But thank you for your response :slight_smile:

I’ve already tried every setting combination, still no success… I’ve been struggling with it for couple weeks now and have tried every guide I was able to find on the internet…

You’re welcome!

Try switching from one to another and see if it works. (CPU > GPU, or GPU > CPU)
As you saw in the animated GIF, it is possible, and it’s working.

Okay, so after some playing with the CPU/GPU and different settings: on CPU rendering there are no shadows, but reflection is fine, on GPU matte catches shadows, but doesn’t reflect objects :confused: