Workspace not saving nor Toolbars nor trays. Sketchup 2023

Good afternoon, anybody got a fix for saving Sketchup preferences/template in Sketchup 2023? When I save my preferences as a template and open a new file from template, it does not save toolbars nor trays, only vray and shortcuts.

Try repairing the installation first. Close SketchUp, find the installer file you downloaded, right click on it, choose Run as administrator, choose Repair when the option is presented. After that open SketchUp, place your toolbars where you need them, make a model or open an existing one and then save it.

Thanks, I will have a go! Just havent had this issue with other versions!

1 Like

Good luck. I initially installed SketchUp 2023 by right clicking on the installer and selecting Run as administrator. Then did as I directed by editing an existing model and saving it after I’d set up my toolbars. Toolbars all stayed put.

Great! With the repair the issue seems to have solved! Perfect, thanks so much

1 Like

Does that apply to the “Display secondary selection pane” button on some tray elements? I like both selection panes open on the Materials tray and every time I open Sketchup 2023, the Materials tray goes back to default. Sketchup 2022 did not do this. All my trays stayed the same way they were when I closed it.

On Windows SketchUp writes the state of the the tray dialogs to a Private Preferences.json which is in User/AppData/Local/SketchUp/… Some users have reported that this file doesn’t get updated when they save and repairing the installation (with Run as administrator) appears to allow Windows to grant permissions to SketchUp to write the file.

You could manually edit the .json file in a text editor and delete the tray related entities.

Save the edit. Then in SketchUp set the trays the way you want them and save the SketchUp file. If SketchUp can write to the file it will rewrite that information.

1 Like

I just did all that and no change. Materials tray back to default. The preference file is being written to. It just seems as though Sketchup is ignoring the settings for the Materials tray. This is how I saved it:

This is how it always comes back when I restart Sketchup:
Not a huge, big deal, I know but just another reason why 2023 is a dud and why I prefer to stay with 2022.

1 Like