This might be a stupid question, but when I start sketch up pro 2020, I cannot see the X on the upper right hand side of the window, (next to minimize, or restore down) to close the application. I have to go to file and quit. I also use multiple monitors for my work so I cannot drag it to another screen. How do you get that back?

Can you get hold of the top bar of the window and drag it down so you can see the X? If you can, then click on the Maximize button to make sure the SketchUp window fills the display.

Hi! Thanks! But no, I cant, that is what’s weird. It looks as if the top of the window was off. So i cannot maximize, or minimize, restore or move the window to another monitor.

Close SketchUp, find the downloaded installer, right click on it, choose Run as administrator and then choose Repair. After it completes, shut the computer down completely and restart it. Any difference?

What is the graphics card?

thanks again. I tried but it told me the version is already installed and I cant go on. Do you suggest I uninstall it and then re-install?

Did you right click on the installer and choose Run as administrator?

Try rebooting the computer and then run the installer as I described.

I did try as admin. Ill restart. thank you!

No dice! I did as you suggested but it keeps on showing it truncated! I cant figure out why! Very frustrating.

To what do you have display scaling set?

??? Sorry, do not understand

I looked it up. It doesnt happen with my other applications or with earlier versions of sketch up.

wow. I just downloaded 2021 and the same thing is happening. No menu bar.

Clearly there’s something going on with your display. Maybe @colin has some bright ideas for you.

Did you install it using the right click and Run as administrator method?

I asked before, what is your graphics card?

hello again. I cannot make the menu bar appear. I downloaded and ran 2021 and the same thing is happening. I need to be able to move it to other screens- and cannot do it at all. If it was a matter of display scale, it would happen with all my applications, no? Futhermore, it doesnt happen with Pro 2018.

dont know- sorry- searched and found the following. image

I ran as admin but it takes me to a window that says to start a free trial. Im on the PRO version

I think that Dave has helped to rule out SketchUp issues. One Windows issue that can happen could lead to the top and bottom of the window being off screen. The work around to that is to point at the SketchUp icon in the task bar, point to the thumbnail of the current window (there may only be one thumbnail), right-click and choose Maximize.

If you try to un-maximize it, it may go back to its offscreen situation, but at least you can get some work done in the meantime.

Try this:
Make sure if the “problematic” SketchUp window is the active. Then push:
⊞Win +Shift +
(Windows Key + Shift + Up Arrow )
This will stretch a window to the top and bottom of the screen. Then you can catch the top bar and move, resize etc…

You can also try
⊞Win +Shift + or
(Windows Key + Shift + left or right Arrow keys )
for moving SketchUp windows between multiple monitors

1 Like

An other method to resize the window with keyboard buttons, follow this instruction exactly:
(Make sure if the “problematic” window is the active.)

  1. Hold down the ALT key. Hit SPACEBAR.
  2. Release ALT key
  3. Hit S (Size).
  4. Hit Up arrow key
  5. Hit Right arrow key
  6. Move your mouse down-left (without pressing any mouse key) until you see the top right corner of window visible
  7. Press left mouse button on the desired place

( Note I assume you have English windows otherwise you may need to replace “S” with a localized start letter of “Size”)

⊞Win +Shift + is a good option, better than maximize because it only sets the top and bottom of the window.

1 Like